19 Replies Latest reply on Nov 14, 2012 2:54 PM by lkstorm1

    How is v10.3 working out for you?

    rgward

      We are a fairly large network running (3) NPM pollers and planning to upgrade this weekend from NPM 10.1.3 / APM 4.2 and trying to determine whether to go with NPM 10.2.2 or 10.3 with SAM 5.0.1.  There have been few reports of issues on this forum so it implies that 10.3 may be pretty stable or not too many customers have upgraded yet since it has only been released for a month or so.  Any positive/negative feedback would be greatly appreciated.  Is 10.3 stable?  Any gotchas?NPM

        • Re: How is v10.3 working out for you?
          branfarm

          My 10.3 upgrade went smoothly and I haven't had any problems.

          1 of 1 people found this helpful
          • Re: How is v10.3 working out for you?
            Deltona

            It's working out very well.

            I'm able to report on the number of monitored APs again.

            I'm able to alert on an AP if it goes down, again.

            I can now load several hundred lines in a view without it timing out.

            Overall performance seems the same as 10.2.X, which was slower than 10.1 if i remember correctly.

            Loving all the new features and love the new graphs!

            1 of 1 people found this helpful
            • Re: How is v10.3 working out for you?
              DirtySouth

              We upgraded from NPM 10.1.3 & APM 4.2. The upgrade itself went perfectly fine. Overall I've been happy with the new features in 10.3 & SAM 5.0.1, especially the hardware monitors. We have about 5300 elements in our environment. We also upgraded to NCM 7.0.2.

               

              The only outstanding issue I see is with the new graphs. I started another thread about that topic.

              • Re: How is v10.3 working out for you?
                jerquiaga

                Our upgrade went smoothly, though we were already on NPM 10.2.2 and SAM 5.0.1. The SAM upgrade has a lot of great new features, especially the hardware monitoring piece. I had been doing it through custom pollers, but the built in stuff is much nicer.

                • Re: How is v10.3 working out for you?
                  Michael Melton

                  I had a hitch in our upgrade, but that was more to the fact that I have two applications running under IIS on the box. I posted the resolution that fixed my issue. But other than that haven't found no other issues of yet.

                  • Re: How is v10.3 working out for you?
                    Scott Sadlocha

                    I upgraded from NPM 10.1.3 to 10.3 last Friday. I did not upgrade SAM at that time, but I did upgrade NCM to 7.0.2. This was my first upgrade as a Solarwinds admin, and I was very nervous about it, especially since it was high visibility in our environment. The NPM upgrade went surprisingly smooth. The only issues I had are with some of the web functionality and with the .NET install on the additional pollers. With the website, I ran into an issue with files being in use. I realized that it was an overhead display monitor we have in our Support Center area. Once I stopped that, it went well. I ran into the .NET issue on our additional pollers, of which we have 2. During the Additional Polller install, I was prompted to install .NET, but it failed everytime on each one. My solution was to download the standalone version of .NET, install it on each server, and then run the upgrade, after which it went fine.

                     

                    NCM upgrade went very smoothly, though it varied greatly for me from the instructions I had on hand, which had me worried initially.

                     

                    Since upgrading, everything has seemed to work very well. It seems that there is a slight performance hit over 10.1.3, but it doesn't seem too bad, just barely noticeable. I am still coming to grips with everything that is changed, but so far I am seeing quite a bit of new information and functionality. I am interested in Deltona's comments on APs, as we had a few issues with that previously. I am going to have to check out what has changed with regard to that when I have some time.

                      • Re: How is v10.3 working out for you?
                        rgward

                        Awesome!  Thanks everyone for all your great feedback!  I really appreciate it.  Well, v10.3 it is! 

                         

                        Unfortunately, I also discovered from this posting, you can only have 2 helpful answers and 1 correct answer in a thread.  I wish I could have marked everyone as correct answer!  Thanks again for all your help!

                      • Re: How is v10.3 working out for you?
                        DirtySouth

                        I started a separate thread about issues I'm having with the new charts. So far I haven't gotten a response, so I'll bring it up here since its directly related to 10.3. I'm noticing inconsistencies between the old charts and the new charts. Thread: "Inconsistencies in Total Bytes Interface Charts".

                         

                        • Re: How is v10.3 working out for you?
                          familyofcrowes

                          We are using it in our Development environment awaiting change control permission to upgrade production.  But so far we have positive feedback.  looking forward to getting it in production.

                          • Re: How is v10.3 working out for you?
                            Marek

                            We upgraded from NPM 10.2 to 10.3 a week+ ago, and immediately following the completion, upgraded IPAM 2.0.1 to 3.0 as well. We also have SAM, NCM, IPSLA , UDT - all at the most current versions.

                             

                            Overall things went smoothly with the upgrades and nearly everything is/was working as expected.

                             

                            ...HOWEVER... We've now found that Groups do not display correctly in "Manage Groups" in the Root Level view, nor are any of our Group alerts showing up or triggering in Advanced Alert Manager - That is a significant issue for us, as we do a lot with alerts on groups! (All other alerts - up/down on Nodes & Interfaces, etc. function properly.)  Also started getting a VSFlexGrid8 unlicensed control popup/splash error following the upgrades when opening Advanced Alert Manager (unsure which product started causing this).

                             

                            I have a case open with Support, but thus far we have not gotten things resolved (more than a week now) - Hoping to not have to uninstall / reinstall, but may be required.  Anyone else have similar issues?  Like all issues, hard to tell initially if it is customer specific (something just in our environment) or an actual bug, etc.

                             

                            All of that said, the new version does bring benefit.

                            Good Luck!

                            • Re: How is v10.3 working out for you?
                              david.templeton

                              I upgraded NPM 10.2 to 10.3 today. The only problem I see so far is that all of the pollers are at 5% Polling Completion.

                               

                              Does anybody know the quick fix for this? We are not using Topology data. I think the fix (also had a problem upgrading to 10.2) involves a change to one of the config files.

                              • Re: How is v10.3 working out for you?
                                pstewart726

                                We upgraded a while ago - shortly after it was released..... the one issue that became evident right after the upgrade is the response time to loading graphs.  The interface details screen for example loads quite quickly (same speed as before) however the actual graph (in our case past 24 hours of interface traffic) takes a LOT longer than 10.2 release did.  I can open a ticket but I seen references to "graph problems" mentioned here and wasn't sure if it was the same issue we are having.  Thank you.

                                  • Re: How is v10.3 working out for you?
                                    david.templeton

                                    I haven't seen any graphing issues yet, but I'm having problems with

                                    polling and alert emails. Right now I'm trying to list the resources on one

                                    device, and it's been stuck with the "Please wait while resources are being

                                    discovered..." message for 5 minutes. Some of the technicians have also

                                    reported a faliure to receive some custom alert emails. Below are some of

                                    the error messages I've found n the logs. Unless I find some answers very

                                    soon, I think I'll need to open a ticket.

                                    **

                                    ConfigurationWizard.log

                                     

                                    2012-06-28 11:15:57,679 DEBUG IIS7Configurator - Parsed IIS binding

                                    string of "*:80:".  Address is "0.0.0.0" and port is "80"

                                    2012-06-28 11:15:57,991 WARN  PluginLoader - Couldn't load assembly

                                    from C:\Program Files (x86)\SolarWinds\Orion\LANsurveyor_DLL.dll

                                    2012-06-28 11:15:58,006 WARN  PluginLoader - Couldn't load assembly

                                    from C:\Program Files (x86)\SolarWinds\Orion\NetPerfMonEventLog.dll

                                    2012-06-28 11:15:58,006 WARN  PluginLoader - Couldn't load assembly

                                    from C:\Program Files (x86)\SolarWinds\Orion\OrionNPMMapEngine.dll

                                    2012-06-28 11:15:58,022 WARN  PluginLoader - Couldn't load assembly

                                    from C:\Program Files (x86)\SolarWinds\Orion\OrionNPMWeb.dll

                                    2012-06-28 11:15:58,022 WARN  PluginLoader - Couldn't load assembly

                                    from C:\Program Files (x86)\SolarWinds\Orion\OrionSWDiscoveryServices9.dll

                                    2012-06-28 11:15:58,022 WARN  PluginLoader - Couldn't load assembly

                                    from C:\Program Files (x86)\SolarWinds\Orion\OrionSWLogger.dll

                                    2012-06-28 11:15:58,022 WARN  PluginLoader - Couldn't load assembly

                                    from C:\Program Files (x86)\SolarWinds\Orion\OrionSWScheduler8.dll

                                    2012-06-28 11:15:58,287 DEBUG PluginLoader - Adding plugin C:\Program

                                    Files

                                    (x86)\SolarWinds\Orion\SolarWinds.ConfigurationWizard.Plugin.NetFlow.dll

                                    with priority 100

                                    2012-06-28 11:15:58,350 DEBUG PluginLoader - Adding plugin C:\Program

                                    Files (x86)\SolarWinds\Orion\SolarWinds.ConfigurationWizard.Plugin.NPM.dll

                                    with priority 50

                                    2012-06-28 11:15:58,365 DEBUG PluginLoader - Adding plugin C:\Program

                                    Files

                                    (x86)\SolarWinds\Orion\SolarWinds.ConfigurationWizard.Plugin.Orion.dll with

                                    priority 1

                                    2012-06-28 11:15:58,365 DEBUG PluginLoader - Adding plugin C:\Program

                                    Files (x86)\SolarWinds\Orion\SolarWinds.ConfigurationWizard.Plugin.VIM.dll

                                    with priority 25

                                    2012-06-28 11:15:58,428 WARN  PluginLoader - Couldn't load assembly

                                    from C:\Program Files

                                    (x86)\SolarWinds\Orion\SolarWinds.Security.Cryptography.X509Certificates.dll

                                    2012-06-28 11:15:58,443 WARN  PluginLoader - Couldn't load assembly

                                    from C:\Program Files (x86)\SolarWinds\Orion\SWAlertActions8.dll

                                    2012-06-28 11:15:58,443 WARN  PluginLoader - Couldn't load assembly

                                    from C:\Program Files (x86)\SolarWinds\Orion\SWAlertEngine8.dll

                                    2012-06-28 11:15:58,443 WARN  PluginLoader - Couldn't load assembly

                                    from C:\Program Files (x86)\SolarWinds\Orion\SWSubClass.dll

                                    2012-06-28 11:15:58,443 WARN  PluginLoader - Couldn't load assembly

                                    from C:\Program Files (x86)\SolarWinds\Orion\SWSysLogActions.dll

                                    2012-06-28 11:15:58,443 WARN  PluginLoader - Couldn't load assembly

                                    from C:\Program Files (x86)\SolarWinds\Orion\SWTrapActions.dll

                                    2012-06-28 11:15:58,443 WARN  PluginLoader - Couldn't load assembly

                                    from C:\Program Files (x86)\SolarWinds\Orion\tdbgpp8.dll

                                    2012-06-28 11:15:58,443 WARN  PluginLoader - Couldn't load assembly

                                    from C:\Program Files (x86)\SolarWinds\Orion\TDBWSnk6.dll

                                    2012-06-28 11:15:58,443 WARN  PluginLoader - Couldn't load assembly

                                    from C:\Program Files (x86)\SolarWinds\Orion\todgub8.dll

                                     

                                    **

                                    OrionWeb.log

                                     

                                    Exception rethrown at :

                                       at

                                    System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage

                                    reqMsg, IMessage retMsg)

                                       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData&

                                    msgData, Int32 type)

                                       at System.ServiceModel.ICommunicationObject.Close()

                                       at SolarWinds.InformationService.Contract2.InfoServiceProxy.Close()

                                    2012-07-05 08:09:20,363 ERROR

                                    SolarWinds.InformationService.Contract2.InfoServiceProxy - Error closing

                                    exception.

                                    System.ServiceModel.CommunicationObjectFaultedException: The communication

                                    object, System.ServiceModel.Channels.ServiceChannel, cannot be used for

                                    communication because it is in the Faulted state.

                                    Server stack trace:

                                       at System.ServiceModel.Channels.CommunicationObject.Close(TimeSpan

                                    timeout)

                                       at System.ServiceModel.Channels.CommunicationObject.Close()

                                    Exception rethrown at :

                                       at

                                    System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage

                                    reqMsg, IMessage retMsg)

                                       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData&

                                    msgData, Int32 type)

                                       at System.ServiceModel.ICommunicationObject.Close()

                                       at SolarWinds.InformationService.Contract2.InfoServiceProxy.Close()

                                    2012-07-05 08:11:55,975 *** Starting SolarWinds Orion Web Site, .Net

                                    Runtime v4.0.30319 ***

                                    2012-07-05 08:11:56,818 WARN  SolarWinds.Orion.Web.ResourceHostManager

                                    - Error processing assembly Interop.Orion8NetPerfMon, Version=3.4.0.0,

                                    Culture=neutral, PublicKeyToken=null.

                                    System.Reflection.ReflectionTypeLoadException: Unable to load one or more

                                    of the requested types. Retrieve the LoaderExceptions property for more

                                    information.

                                       at System.Reflection.RuntimeModule.GetTypes(RuntimeModule module)

                                       at System.Reflection.RuntimeModule.GetTypes()

                                       at System.Reflection.Assembly.GetTypes()

                                       at SolarWinds.Orion.Web.ResourceHostManager.Initialize()

                                    2012-07-05 08:53:41,867 ERROR ASP.global_asax -

                                    Application_Error(58658f66b401466fa7660c27a5b0aaa4)

                                    System.Web.HttpException (0x80004005): Request timed out.

                                     

                                    NPM.BusinessLayer.log

                                     

                                    2012-07-05 09:02:47,328 WARN

                                    SolarWinds.NPM.BusinessLayer.CustomPollerJobSchedulerEventsService - Custom

                                    poller error: 31040: Timeout  (assignment

                                    e2962847-f759-438e-810e-75a90b6f2bcf on node 90354)

                                    2012-07-05 09:02:47,328 WARN

                                    SolarWinds.NPM.BusinessLayer.CustomPollerJobSchedulerEventsService - Custom

                                    poller error: 31040: Timeout  (assignment

                                    07b0f40f-e6db-48a5-a8ef-7a192f6bd153 on node 90354)

                                    2012-07-05 09:02:47,328 WARN

                                    SolarWinds.NPM.BusinessLayer.CustomPollerJobSchedulerEventsService - Custom

                                    poller error: 31040: Timeout  (assignment

                                    e7a8a704-952b-4b17-8725-92e8c900c776 on node 90354)

                                    2012-07-05 09:02:47,328 INFO

                                    SolarWinds.NPM.BusinessLayer.CustomPollerJobSchedulerEventsService - Custom

                                    poller error: Unable to complete transform. (node 90354)

                                     

                                    BusinessLayerHost.log

                                    **

                                     

                                    2012-06-28 17:52:26,393 WARN

                                    SolarWinds.Orion.Core.Common.ServiceHelper - Waiting for SWIS v2.0 start.

                                    Attempt 1, exception message: "There was no endpoint listening at

                                    net.tcp://npm:17777/SolarWinds/InformationService/Orion/ssl that could

                                    accept the message. This is often caused by an incorrect address or SOAP

                                    action. See InnerException, if present, for more details."

                                    2012-06-28 17:52:31,509 WARN

                                    SolarWinds.Orion.Core.Common.ServiceHelper - Waiting for SWIS v2.0 start.

                                    Attempt 2, exception message: "There was no endpoint listening at

                                    net.tcp://npm:17777/SolarWinds/InformationService/Orion/ssl that could

                                    accept the message. This is often caused by an incorrect address or SOAP

                                    action. See InnerException, if present, for more details."

                                     

                                     

                                    Thanks,

                                    David Templeton

                                    Troy Cablevision, Inc.

                                     

                                     

                                     

                                    On Tue, Jul 3, 2012 at 2:14 PM, nexicom <

                                      • Re: How is v10.3 working out for you?
                                        david.templeton

                                        A SolarWinds tech remoted into my system and fixed most of the problems. All pollers are still showing 5% completion, but that's a setting bug (involving Topology) that I didn't mention to him. The main issue was listing resources, where it failed more often than it worked.

                                         

                                        Before he connected, I noticed a problem on the additional pollers. Where normally the might be around a dozen instances of SWJobEngineWorker running, the pollers had between 48 and 65 instances running. Physical memory was pegged out. First, we shut down everything in the orion service manager. Then, we went to %PROGRAMDATA%\SolarWinds\Installers. We uninstalled/reinstalled JobEngine.V2, followed by CollectorInstaller. This was done on every machine.

                                         

                                        It seems to take longer than before the upgrade to 10.2, but listing resources works much better now.