5 Replies Latest reply on Mar 8, 2013 10:37 AM by Mobasin IT

    Unable to publish updates

    SolarWinds Community Team

       

      For some reason, when I attempt to publish packages (be it one I just created by hand or one that is part of the subscription package), the publish action fails with the message:

       

      Failed to publish <insert package name here>.  The specified item could not be found in the database.

       

      Has anyone seen this before?   What would cause this? 

       

      Thank you!

       

        • Re: Unable to publish updates
          SolarWinds Community Team

           

          Hi memach,

          Are your EminentWare (now called Patch Manager) server and your WSUS server both on the same machine?

          Can you try the following?:

           

          • Add a credential to Patch Manager for your server's built-in local Administrator account under EminentWare Syestem Configuration -> Security and User Management -> Credentials tab.  Since it is local, you can use the format "dot backslash Administrator", like this:    .\Administrator
          • Go to the Credential Rings tab, open your user's assigned Credential Ring (this will be <Default> unless you've configured it differently)
          • On the first page of the Credential Ring Wizard, Add the credential so it shows in the bottom pane.
          • On the next page of the wizard, create a Computer Rule for your server and assign the .\Administrator account to be used when communicating with that server.
          • Attempt to publish again.

          If you need help with the above, Credentials and Credential Rings are discussed in section 4.2 of our Administation Guide.

          -Kelly

           

            • Re: Unable to publish updates
              SolarWinds Community Team

               

              Hi Kelly,

              I probably should have given a little more detail.   We have had Eminentware up and running for a couple years now.  It's been working just fine with the existing credentials until now.  It just all of a sudden quit working.

              Eminentware resides on a Windows XP system.  WSUS resides on a Windows 2003 server with SQL 2005.

              If you think I still need to run through the credentials and create new ones, please let me know and I can try that.  But like I said, the existing ones have been working for at least a couple years.

              -Ken

               

                • Re: Unable to publish updates
                  SolarWinds Community Team

                   

                  Hi Ken,

                  Can you gather a set of logs for us and send those in to customersupport@eminentware.com?  Instructions follow:

                   

                   

                  Steps:

                  1. Go to EminentWare System Configuration -> EminentWare Servers
                  2. Select your Primary Application Server in the middle pane
                  3. Click Automation Server Settings tab in bottom middle pane
                  4. Set “Logging Output” to 3
                  5. Set “Enable Logging” to 1
                  6. Retry the step that caused the error
                  7. Turn off logging by going back and setting “Enable Logging” to 0     <-- important step!
                  8. Send us the Worker Process and DataGrid Service log(s) generated by the process.  They can be found under Program Files\EminentWare\Server. It is usually easiest just to sort by modified date to find them.  If only one of those two log files is present that is OK.
                • Re: Unable to publish updates
                  Mobasin IT

                  I was having the same issues when trying to deploy multible adobe reader updates, if I publish one-by-one I don't get the error.

                • Re: Unable to publish updates
                  callidus

                  Came to this problem a few days ago, too. The root cause (in my case) was that the package I wanted to deploy was not published before and I checked the "re-sign existing package" option. For newly published packages this option has to be de-selected.