3 Replies Latest reply on Jun 26, 2012 9:41 PM by Steve Welsh

    Cisco WLC Device.Backup.TFTP Not working

    keber314

      When I try to run a job on my Cisco WLC's using Device.Backup.TFTP I receive no error, but when I go to the directory where the backups should be I find no files.

       

      I tried running a Device.CLI.Send.Commands and I received the following error: "Aborting command entry due to command error".  The command i tried running was "show run".

       

      Also this process used to work, but now all of a sudden it stopped working.

       

       

      KiwiCat tools version 3.4

       

      WLC IOS 7.0.230.0

       

       

       

       

      Thanks for your help in advance.

       

      Paul


        • Re: Cisco WLC Device.Backup.TFTP Not working
          Steve Welsh

          Hi Paul,

           

          There was an update to the Device.Backup.TFTP activity in 3.7.0 release which fixes a couple of issues specifically with TFTP file backup for Cisco WLC.

           

          I think also you may be using the wrong command for TFTP backup.  In the Options tab of the Device.Backup.TFTP activity, you should be using config in the 'File to write to TFTP server' field.

           

          Give this a try and post back to the forum your results.

           

          Regards,

           

          Steve

            • Re: Cisco WLC Device.Backup.TFTP Not working
              keber314

              Steve,

               

              We are currently running on the 3.4 version and our support has expired.   Are we able to upgrade since this is a bug or do we have to pay for support again in order to upgrade versions?

               

              When I try the suggested solution mentioned in your above post, I do not get any errors nor do I get a backup of the config.

               

               

               

              One work around I found was:

               

              Run a job with this information:

              Type: Device.CLI.Send commands

               

              Under the Options tab:

               

              transfer upload serverip 10.0.0.1   (server IP where KIWI lives)

              transfer upload filename %DeviceName%.cfg

              transfer upload mode tftp

              transfer upload path /

              transfer upload datatype config

              transfer upload start

               

               

              Save device output to: C:\Program Files\CatTools3\Captured Data\%GroupName%\%DeviceName%.DeviceOutput.%DateISO%.txt

               

              This way each file is a unique one.  This does not give me dated configs, but it gives me the current config at the time.  The old ones get overwritten.


                • Re: Cisco WLC Device.Backup.TFTP Not working
                  Steve Welsh

                  Hi Paul,

                   

                  Your workaround is a good one, but like you say you don't get the Dated configs using the Device.CLI.Send commands method.

                   

                  My previous solution is dependent on you being on the current release of CatTools.  If you want to verify it works, then you could download the latest release EVAL version and install on a 'test' windows system (i.e. not on your production system) and run the activity.

                   

                  With regards to the upgrade question, I'd recommend you raise this with support or your sales rep so they can check your details.

                   

                  Regards,

                   

                  Steve

                  1 of 1 people found this helpful