2 Replies Latest reply on May 7, 2012 1:46 PM by kable

    EminentwareWare custom package failures

    kable

      We've installed EminentWare 1.71.210.1 with the 3rd Party updates extensions. Windows updates work fine, the pre-packaged catalog of updates (Mozilla FireFox, Adobe Reader etc.) work fine but I'm having trouble with custom packages. SolarWinds support got me pointed in the right direction but were unable to resolve my problem. I'm trying to do an install of FileHold and RightFax. I've found information from both vendors on how to perform a silent install. The commands work when running them from the command line directly on the local machines but when you put them into EminentWare it doesn't seem to take the whole command string. For example;

       

      With FileHold you run filehold.exe  /S /V/qn /vALLUSERS=1 which tells it to install silently with default options for all users. This works for the install when running from the command line directly on the client machine. If you leave off the /vALLUSERS=1 all it does is put all the files in c:\program files\ which is what happens when you push the product through EminentWare despite the additional switch of /vALLUSERS=1

       

      RightFax is a bit more tricky. It uses an executable which points to an xml file which points to the MSI, if you try to run the MSI directly you get an error that you must use the .exe to install the program so simply creating a transform from the MSI is out of the question. From their documentation they give you the command line switches to run silently, point you to the path of the xml if its not in the directory, which options to install, and your RightFax server name. So the command I've applied is rightfax.exe /quiet=true /manifest=”\\servershare\locationt” /allowShutdown=false /add=”FaxUtil,EFM” /rightFaxServer=”ourserver”. When I run this through EminentWare it fails saying "Install failed. Fatal error during installation HRESULT: 0x80070643". This command works fine on the client when running from the command line even when you map the location of the setup.exe file to the location on the EminentWare server and run it that way.

       

      There is just something not working right with the push and to me it seems its not applying all of the commands. I've built a package using the same method to install CutePDF which worked worked, all that needed was a /verysilent switch.

       

      Thanks in advance for any assistance.

        • Re: EminentwareWare custom package failures
          Lawrence Garvin

          For the RightFax question, the limitation is simply one of network access. Because all updates are installed in the context of the SYSTEM user (by the WUAgent), there is no network access. The installation is likely failing because your /manifest reference is not accessible. The best way to handle this is by using the Additional Files option of the Package Wizard, and including the XML in the CAB being sent to the client. In this instance the XMLfile is now in the local directory. Since the /manifest value seems to be a folderName, not a fileName, it may be that the option is not even required (hopefully it defaults to the local folder).

           

          For the FileHold question, I'm a bit confused as to the actual issue. If I'm understanding you correctly, it seems that you've described the issue that the /vALLUSERS=1 parameter is being ignored when installed via the WUAgent. But if the files end up in C:\Program Files -- that would be the expected behavior in any event. What behavior do you observe when installing from the command line with the /vALLUSERS=1 parameter present? (Note: The WUAgent cannot do per-users installations, so unless the product defaults to a per-user installation, the presence or absence of such a parameter is probably insignifcant.)

            • Re: EminentwareWare custom package failures
              kable

              For the RightFax I have tried including all the files in the package including the manifest file and I get the same result. I've even tried dropping the command that points to where the minifest file is located when adding the files in the package. After searching the internet I did find some people were having issues pushing RightFax over SCCM and they had to enable user interaction to get it to work even though its a silent install. I've tried enabling the same option in EminentWare but then I get a different error "Install failed. The update does not support the current action (install or uninstall) HRESULT: 0x80242004". I tried enabling this option on a package I created that works for CutePDF and I get the same error. Does this function actually work?

               

              For FileHold if you manually launch the executable (not a command line install) it will be installed for all users (listed in the start menu under program files and listed in add/remove programs as a program you can uninstall). I did some further testing and my original post was wrong. If you run the install from the command line without the /ALLUSERS=1 switch it will just install for the current user. If you log in as another user you will not see it in the start menu or add/remove programs so if you are correct that the WUAgent ignores an indication to install for all users then that is probably the problem.