6 Replies Latest reply on Jul 1, 2013 2:40 PM by brian lee

    Advanced Alert Manager error

    phreakingeek

      Hi All,

       

      I've used Solarwinds a number of times in the past and this is the first time I've encountered this issue.  I am able to open Advanced Alert Manager and modify the default alert and add any alert except for the E-Mail alerts.  If I add the E-mail alert, it shows up in the Trigger Actions as a blank line...and when I try to edit the alert, I receive run time errors.  First one is Run-time Error '0'  when you click OK, you get another one that says Run-Time error '-2147418105 (80010007)':

       

      I did a couple of screen shots to help explain what I am experiencing.  Hopefully someone who's already run accross this issue can point me in the right direction. 

       

      I thought that a simple reinstall would fix it, but since it doesn't look like you cant do a repair, I'm stuck doing a full uninstall before I can attempt a reinstall.

        • Re: Advanced Alert Manager error
          summey

          I have the same exact issue anyone found a solution?

          • Re: Advanced Alert Manager error
            phreakingeek

            I did an uninstall and reinstall of .NET, NPM, APM, Engineer Toolset, and all of the other junk bundled with this product...it's working now.  No idea why it broke or which applicaiton in the long drawn out install fixed it.  I wish the products had a "Repair" option!

              • Re: Advanced Alert Manager error
                summey

                AHHH GROSS!!! ok Ill give this a shot.

                 

                 

                Thank you

                • Re: Advanced Alert Manager error
                  bhooper

                  phreakingeek wrote:

                   

                  I did an uninstall and reinstall of .NET, NPM, APM, Engineer Toolset, and all of the other junk bundled with this product...it's working now.  No idea why it broke or which applicaiton in the long drawn out install fixed it.  I wish the products had a "Repair" option!

                   

                   

                   

                  Actually - There is a repair option available - On a 2008 R2 Server - under C:\ProgramData\Solarwinds\Installers - there is an .msi for the CoreInstaller.  If you run that, it will give you the repair option.  After it completes the repair - you have to go back through the configuration wizard.

                   

                   

                  After completing these steps on my server, my Advanced Alert Manager worked properly.  Hate to see you guys uninstalled everything to get this working.

                    • Re: Advanced Alert Manager error
                      fortch

                      Thread is a bit old, but I thought I'd post my findings after running into this exact issue -- strangely enough, after running a repair (Programs and Features for the Core Application) and canceling the configuration, everything is back to working normal. It was a gamble, but I figured it would just use the existing configuration....which it seems to have

                  • Re: Advanced Alert Manager error
                    brian lee

                    Are you seeing any other problems with any of your other modules?  between all your pollers or DB? Did you run the configuration wizard after your updates? When did it break? Was it around an reboot/ install?