10 Replies Latest reply on Apr 18, 2012 2:45 PM by jbruyet

    SQL Server running low on space

    jbruyet

      Hey all, I'm running NPM 10.2.2 with 47  Nodes, 87 Interfaces and 66 volumes being monitored. I had my SQL guy help me get NPM pointed over to our SQL box and now we're running low on drive space on the SQL server. Deke checked and SolarWinds is using 29 gigs for the SolarWinds database and 22 gigs for the log files. We've backed up SQL thinking that would erase the log files but they're all still there. I changed the retention scheme so that I'm only keeping 180 days of history but we're still running low on drive space. Is there anything else I can do that would help conserve drive space on the SQL server?


      Thanks,


      Joe B

        • Re: SQL Server running low on space
          mdriskell

          Ask your SQL guy what table is filling up the most?  That seems awfully big for only 47 nodes.  For instance I have 18000 elements and I'm nowhere near that large of space used.

           

          Are you doing SNMP trapping or Syslogging?  Those can contain large amounts of text that could easily begin to fill the tables.

            • Re: SQL Server running low on space
              jbruyet

              Hi Mike, I don't recall configuring any Syslogging or SNMP Trapping when I was setting up my NPM but that doesn't mean I didn't. Where would I look to see if those things have been configured?

               

              My SQL guy just checked and the table that's filling up is TrapVarBinds. If I AM doing SNMP Trapping how do I turn it off?

               

              Thanks,

               

              Joe B

                • Re: SQL Server running low on space
                  mdriskell

                  TrapVarbinds is the table utilized for SNMP trapping.  One method if you truly aren't using SNMP trapping is to disable the service (sorry I'm at home and don't have the actual service name handy).  It sounds to me like one or more of your devices is configured to send traps to solarwinds.  If this is not desired I would suggest to shut off sending of traps to your server completely. 

                   

                  This same thing happened to me years ago when an OSPF flood caused so many traps that my DB grew from 5GB to 45GB in less than a week.  The devices were mistakenly configured to send traps to SW even though I was already polling for the same data and it wasn't needed.

              • Re: SQL Server running low on space
                netlogix

                Oh, switch the DB to simple not full recovery model.  Unless you are doing SQL replication, and in that case, shorten you time window between log shipments or check to see why the target or source sql server is not letting go of those logs.  In either case, right click the database and shrink it, you should get most of those 22 gb back.

                 

                you should check this post Byron did about syslog, same principle applies to snmptraps.

                 

                Or just stop the solarwinds snmptrap

                1 of 1 people found this helpful
                • Re: SQL Server running low on space
                  jbruyet

                  Hi Andrew Pacetti, I checked SysLog and Total Space Usage is 0 bytes.

                  Hi netlogix, my SQL guy has already shrunk the... I don't know if it was a table or a database but we went from 22 gigs for TrapVarBinds down to 9.2 gigs. I don't remember the name of the other... table/DB that he shrank. This sounds like a temporary fix because even if it was shrank it should still grow again unless I can get the problem figured out.

                   

                  And I think I did that. Thanks Mike Driskell and netlogix, I saw that my SolarWinds Trap Service was set to auto and was running. I just changed it to manual and stopped the service. I'll keep an eye on things and see if this helps with my disk space problem. I see the SolarWinds Syslog Service is running but since my SysLog database showed 0 bytes I just left it alone.

                   

                  Thanks for the help everyone,

                   

                  Joe B