2 Replies Latest reply on Mar 26, 2012 11:15 PM by wanine39

    Engineers toolset , Workplace Studio  v10.7-HotFix4 fails to start

    wanine39

      hello

      i had the engineers toolset running on my Win 7 x64 laptop with 4 GB ram

      after the latest set of MS patches and 10.7 hotfix 4, the sw no longer starts

      when in start Workplace Studio, the splash page appears for 0.5 seconds, moves to another part of the screen for 0.1 seconds and then quits.
      there are no MS OS event logs reported

      I need to use this tool to run and work again as we have an important need for it to complete some urgent work. 

      I use to be able to use and depend on the tool; not now. There are no relevant posting in twack on this problem

      i have also opened a ticket, no response yet

      please advise if anyone else has seen this. if so, any workaround or soln?

        • Re: Engineers toolset , Workplace Studio  v10.7-HotFix4 fails to start
          SteveSW

          Sorry you are having troubles. This is a new to us. We've had no known reports of anything like you described. Please open a ticket with support and reference this thread so we can work more closely to help you. Support will ask you for verbose logs for Workspace Studio.

          You can turn on logging by locating the WorkspaceStudio.exe.config  file usually located in <Program Files>\SolarWinds\Toolset. Make  sure the Workspace Studio is closed and there are no running processes named WorkSpaceStudio.exe, then open the config file and  change all of the <level value="OFF" /> to <level value="ON"  />. See below for excerpt of config file:
           
           
              <root>
                <level value="ALL"/>
                <appender-ref ref="RollingLogFileAppender"/>
                <appender-ref ref="OutputDebugStringAppender"/>
                <appender-ref ref="DebugAppender"/>
              </root>
              <logger name="SolarWinds.Toolset.IEE.CommonPollingEngine.InterfacePoller">
                <additivity value="true" />
                <level value="OFF" />
              </logger>
              <logger name="SolarWinds.Toolset.IEE.CommonPollingEngine.PollingEngine">
                <additivity value="true" />
                <level value="OFF" />
              </logger>
              <logger name="SolarWinds.Toolset.IEE.HostApp.EntryPoint">
                <additivity value="true" />
                <level value="OFF" />
              </logger>
              <logger name="SolarWinds.Toolset.IEE.Gui.DashboardForm">
                <additivity value="true" />
                <level value="OFF" />
              </logger>
              <logger name="Scheduler">
                <additivity value="true" />
                <level value="OFF" />
              </logger>
              <logger name="ResponseTimePollerLog">
                <additivity value="true" />
                <level value="OFF" />
              </logger>
              <logger name="DeviceManager">
                <additivity value="true" />
                <level value="OFF" />
              </logger>
              <logger name="SolarWinds.Toolset.IEE.ActivePoller">
                <additivity value="true" />
                <level value="OFF" />
              </logger>
              <logger name="SolarWinds.Toolset.IEE.UpdateChecker">
                <additivity value="true" />
                <level value="OFF" />
              </logger>
              <logger name="SysInfoPollerLog">
                <additivity value="true" />
                <level value="OFF" />
              </logger>
              <logger name="TFTPServer.Instance">
                <additivity value="true" />
                <level value="OFF" />
              </logger>
              <logger name="SolarWinds.Toolset.IEE.HostApp.AppLoader">
                <additivity value="true" />
                <level value="ERROR" />
              </logger>
           
          Then start up the Workspace Studio and reproduce the problem. The logs can be found at:
          <ALL USERS PROFILE>Application Data\SolarWinds. Look for "...-Dashboard.log..." files.
          --HTH
          Steve

            • Re: Engineers toolset , Workplace Studio  v10.7-HotFix4 fails to start
              wanine39

              hello:

              thank you

              i have ticket 326939

              i sent the logs to <TechnicalSupportFeedback@solarwinds.com>

               

              here is a subset of the logs with debug on. this log segments is repeated 30 times, each time i try to run and start the workspace

              i have a valid license and active mtce contract

               

              2012-03-27 00:38:15,261 [1] DEBUG SolarWinds.Toolset.IEE.LicenseProvider - Caught exception instantiating LicenseManager:
              SolarWinds.Licensing.Framework.Store.LicenseStoreException: An exception was thrown while initializing license store. See inner exception. ---> SolarWinds.Licensing.Framework.Store.LicenseStoreException: Exception of type 'SolarWinds.Licensing.Framework.Store.LicenseStoreException' was thrown.
                 at SolarWinds.Licensing.Framework.Store.LicenseStoreDAL.ValidateStoreHash(Byte[] storeBytes)
                 at SolarWinds.Licensing.Framework.Store.LicenseStoreDAL.LoadDataMutexed()
                 --- End of inner exception stack trace ---
                 at SolarWinds.Licensing.Framework.Store.LicenseStoreDAL.LoadDataMutexed()
                 at SolarWinds.Licensing.Framework.Store.LicenseStoreDAL.LoadData()
                 at SolarWinds.Licensing.Framework.Store.LicenseStoreDAL.InitializeStore()
                 at SolarWinds.Licensing.Framework.Store.LicenseStoreDAL..ctor()
                 at SolarWinds.Licensing.Framework.Store.SingletonLicenseStoreFactory.get_StoreInstance()
                 at SolarWinds.Licensing.Framework.LicenseManager..ctor(ILicenseStore store)
                 at SolarWinds.Licensing.Framework.LicenseManager..ctor()
                 at SolarWinds.Toolset.IEE.LicenseProvider.GetLicense(Boolean interactive, Boolean retry, Boolean fixShortcuts)
              2012-03-27 00:38:15,464 [5] DEBUG EntryPoint - Listening on IPC channel SolarWinds_IEE_1_Channel.