1 Reply Latest reply on Mar 23, 2012 6:33 AM by hple98

    Datediff error when upgrading from 3.8 to 3.9

    hple98

      To all,

      Have anyone seem this error before? How do I resolve this problem.

      Database configuration failed:

           •  Error while executing script- The datediff function resulted in an overflow. The number of dateparts separating two date/time instances is too large. Try to use datediff with a less precise datepart.

      The statement has been terminated.

      Thanks,

      Le

        • Re: Datediff error when upgrading from 3.8 to 3.9
          hple98

          Hotfix for 3.9 fixed the problem.

          "SolarWinds NetFlow Traffic Analyzer version 3.9 Hotfix 1

          Hotfix 1 corrects an error with the Configuration Wizard during ugrade to NTA 3.9 resulting from a script that compares date-stamp differences in between current and older CBQoS data. If you are upgrading to NTA version 3.9, and you already have a large amount of CBQoS data in your database--based on collections related to 200 or more different policies--and you are currently not collecting CBQoS data from your devices, you should first install NTA 3.9 HotFix1 before upgrading.

          This hotfix requires NTA version 3.7 or 3.8.

          Warning: This fix momentarily stops and restarts your Orion Web Console.

          This HotFix should be installed before an upgrade to Orion NTA 3.9
          or upon failure of an Orion NTA 3.9 upgrade with the following error:

              Error while executing script - The datediff function resulted in an
              overflow. The number of dateparts separating two date/time instances is
              too large. Try to use datediff with a less precise datepart. The statement
              has been terminated."