3 Replies Latest reply on Mar 8, 2012 10:07 PM by Steve Welsh

    Authentication problem with a Cisco VG224

    dfawley

      Hello all.

       

      I'm using the evaluation version of Cattools and backing up most of my devices successfully.  I am having problems with a Cisco VG224 (voice gateway).  I am using the device type of Cisco.Router.General and am having problems authenticating to the device.  Here is the capture:

       

      <NEWSESSION CatTools 3.6.0 3/7/2012 8:50:11 AM>

      <PROTOCOL=Telnet>

      <DEVICE TYPE=Cisco.Router.General>

      <ACTIVITY TYPE=Device.Backup.Running Config>

      <ACTIVITY SCRIPT=C:\Program Files\CatTools3\Scripts\Client.Device.Backup.Running Config.txt>

      <USERS NAME FOR DEVICE=BR25_VG224-01>

      <C OK 8:50:11 AM><R-8:50:11 AM>[13][10][13][10]User Access Verification[13][10][13][10]Username: <W-8:50:11 AM>********[13]<R-8:50:12 AM>********[13][10]Password: <W-8:50:12 AM>********[13]<R-8:50:12 AM>[13][10][13][10]Password: <R-8:50:42 AM>[13][10]% Password:  timeout expired!<D 8:50:44 AM>

      <SCRIPT VALUES>

      <HOSTNAME="">

      <PROMPT VTY="">

      <PROMPT ENABLE="">

      <PROMPT CONFIG="">

       

       

      ================================================================================

      WFMDRetVal=1 Waiting for: ">"

      WFMDRetVal=2 Waiting for: "#"

      WFMDRetVal=3 Waiting for: "% Login invalid"

      WFMDRetVal=4 Waiting for: "% Authentication failed"

      WFMDBuffer="[13][10][13][10]password: [13][10]% password:  timeout expired!"

      ================================================================================

       

      ================================================================================

      WFMDRetVal=1 Waiting for: "% Login invalid"

      WFMDRetVal=2 Waiting for: "% Authentication failed"

      WFMDRetVal=3 Waiting for: "Username:"

      WFMDRetVal=4 Waiting for: "Password:"

      WFMDBuffer=""

      ================================================================================

       

      ================================================================================

      WFMDRetVal=1 Waiting for: "% Login invalid"

      WFMDRetVal=2 Waiting for: "% Authentication failed"

      WFMDRetVal=3 Waiting for: "Username:"

      WFMDRetVal=4 Waiting for: "Password:"

      WFMDBuffer=""

      ================================================================================

      The device requires the password to be entered twice.
      Here is the log when I telnet into the device:
      User Access Verification
      Username: ***************
      Password:
      Password:
      vg224-01>

      This is frustrating as I have a second voice gateway configured that works - this is a direct copy of that with only the IP and passwords changed.  

       

      Any ideas?  I'm not exactly sure how to read the capture file, but it appears the password isn't being entered?

        • Re: Authentication problem with a Cisco VG224
          Steve Welsh

          Hi dfawley

          From the logs I can tell that CatTools is sending the password for the first password prompt on your device; however because your device is returning the password prompt a second time, CatTools is most likely interpreting this as an authentication failure and so re-attempts to log in.

          The Info Log pane (and infolog.txt file found in the CatTools install folder) would give more of an indication as to what the script is doing.

           

          The big question though is why does the device require the password to be entered twice?   This is somewhat non-standard behaviour for most devices and is the cause of the problem you are having.

          Can you provide any more info as to why this occurs for this particular device?   Does this occur on the other voice gateway?

           

          Regards,

          Steve