4 Replies Latest reply on Mar 9, 2012 11:19 PM by nrms

    Noobie Alert writer that I am..........

    pduffany

      Hi,

      I have an alert that tests ok (I receive the email), but when I test it doesn't alarm/alert.

      This is to monitor power supplies:

      Trigger Condition:

      All apply:

      System OID is equal to 1.3.6.1.4.1.9.9.13.1.5.1.4

      MIB is equal to CISCO-ACCESS-ENVMON-MIB:ciscoAccessEnvMonMIB

      field Severity is equal to value 0

       

      Please let me know what I am doing wrong (probably multiple things), I have tried several modifications to this trigger and the test works, but the actual alert doesn't fire when I disconnect one of the Power Supplies on a dual power supply Cisco Switch.

        • Re: Noobie Alert writer that I am..........
          nrms

          From what Engineers Toolset is telling me, the OID you reference is probably not the one you want to be monitoring:

          CISCO-ENVMON-MIB:ciscoEnvMonSupplySource

          OID: 1.3.6.1.4.1.9.9.13.1.5.1.4
          Access: Read-Only
          Type: Integer

          The power supply source.
           unknown - Power supply source unknown
           ac - AC power supply
           dc - DC power supply
           externalPowerSupply - External power supply
           internalRedundant - Internal redundant power supply
          Possible values:
          unknown(1)
          ac(2)
          dc(3)
          externalPowerSupply(4)
          internalRedundant(5)

          I suspect you may want to have a look at 1.3.6.1.4.1.9.9.13.1.5.1.3 instead as this is the Supply State. The Cisco MIB Browser for this field is at the following URL:

          http://tools.cisco.com/Support/SNMP/do/BrowseOID.do?objectInput=1.3.6.1.4.1.9.9.13.1.5.1.3&translate=Translate&submitValue=SUBMIT

          If it still doesn't work it'd be worth doing an SNMP walk on the Cisco OID tree with the PSU in and then again with it removed and see what has changed.

            • Re: Noobie Alert writer that I am..........
              pduffany

              Thank you for the help nrms.

              I tried the OID you suggested and still not alerting when I down the Power Supply.

              UnDP
              Has 1.3.6.1.4.1.9.9.13.1.5.1.3 defined in Poller and assigned to 4948 as:
              Raw Value
              Format is Text
              Get type is Get Table
              Polling type is Node.
              Status is Enabled

              I did the snmpwalk but only found counters that were different.

              I did find a couple of OID's in the output that address power supplies though:

              SNMPv2-SMI::mib-2.47.1.1.1.1.2.11 = STRING: "Power Supply ( AC 300W )"
              SNMPv2-SMI::mib-2.47.1.1.1.1.2.8 = STRING: "Power Supply ( AC 300W )"

              SNMPv2-SMI::mib-2.47.1.1.1.1.7.8 = STRING: "Power Supply 1"
              SNMPv2-SMI::mib-2.47.1.1.1.1.7.11 = STRING: "Power Supply 2"

              Should I use those instead?

               

              Paul