4 Replies Latest reply on Jan 14, 2016 4:17 AM by wallyollie

    Disabling the mobile view?

    jase4772

      Hi,

      Is there anyway to stop the mobile view from being used on an iPhone/iPad? I've tried changing the string to false on the URL but the minute you load a node it keeps changing back.

      Thanks

      Jason

        • Re: Disabling the mobile view?
          DanielleH

          Hi Jason--

          Have you seen the steps in this KB article?  Also, check out Stuck in Mobile Mode discussion.  You might be able to get some assistance from the members on that thread.

          Thanks!
          DH

            • Re: Disabling the mobile view?
              jase4772

              Hi,

              That KB article worked a treat and I can now get the full browser experience on my iPhone and iPad. Shame the support call I logged with Solarwinds didn't point me at that article!

              Incase anyone wants to do the same the settings that worked for me (I've not idea really what it means) is as follows :-

              <!-- iPhone -->
                <device user_agent="Mozilla/5.0 (iPhone; CPU" fall_back="generic_web_browser" id="safari">
                 <group id="product_info">
                  <capability value="4.0" name="model_name" value="5.1" />
                 </group>
                </device>

                <!-- iPad -->
                <device user_agent="Mozilla/5.0 (iPad; CPU" fall_back="generic_web_browser" id="safari">
                 <group id="product_info">
                  <capability value="4.0" name="model_name" value="5.1" />
                 </group>
                </device>

              Many thanks

              Jase

            • Re: Disabling the mobile view?
              wallyollie

              hi, this version no longer works. here is the new version that will resolve the issues and disable mobile view (which is terrible)

              The Information Service is responsible for enforcing the limitations, the Mobile View cannot change this. You can try to disable Mobile View, but I don't think that will help:


              1. Make a backup of and edit the following file:C:\inetpub\SolarWinds\Web.config


              2. Find the following line:


              <add key="EnableAutodetectMobileDevices" value="true" />


              and change it to the following:


              <add key="EnableAutodetectMobileDevices" value="false" />


              3. Restart the World Wide Web Publishing Service