8 Replies Latest reply on Dec 18, 2011 7:25 PM by Steve Welsh

    Cat Tools Data Execution Prevention error

    ktatum

      I am running Cat Tools on a Windows 2008 server.  On 11/21 there were multiple security and regular updates for windows that were pushed to this server.  Since that date I cannot get Cat Tools to load at all.  Running the program gives me a Microsoft error saying SolarWinds CatTools has stopped running.  Details of the problem show:

      Problem signature:

        Problem even name:  BEX

        Application Name:  CatTools_Manager.exe

        Application Version:  3.6.0.0

      The only options are to close the program or to check online for a solution and close the program.  Checking online for a solution says to help protect my computer, Data Execution Prevention has closed Cat Tools.  I went through the steps of turning on DEP for only Windows essential windows programs and also turned it on for all programs and listed Cattools as an exception.  Neither worked.  I also went through the steps of going to the command line and running bcdedit and turning off DEP totally, and also disabling PAE.  Rebooted the system and still the same error.  I am not sure how I am still getting a DEP error with DEP turned off.

      Any way to fix this without going through the 38 various windows updates from 11/21 and uninstalling them to see which one(s) may have broken this?  I'm sure this will pop up again if I dont fix the root cause of it.

      Thanks for any help!

        • Re: Cat Tools Data Execution Prevention error
          Steve Welsh

          Hi ktatum,

          This issue is something we are currently investigating.   To date there has been just one other report of it being a problem and from what that customer has been able to find, its related to a security fix in Microsoft Update KB2533623 and relates only to x64 Windows O/S.

          Also on that customers machine, regsvr32 can no longer be run on their machine (which is quite a problem in itself).

          Can you confirm for me please the following:

          1) the Windows edition you are running (x86 or x64)?

          2) are you able to manually register .dll's?

          Thanks,

          Steve