3 Replies Latest reply on Nov 23, 2011 8:37 AM by RickyP

    Enabling SSL

    RickyP

      Hi,

      I'm tring to enable SSL on Storage Manager. I'm following the instructions under the help section of the product but it does not seem to work. Has anyone had any issues enabling SSL? Any tips on what the issue may be?

       

      Thanks in adavnce

      RickyP

        • Re: Enabling SSL
          mark wiggans

          Here are the fields that need to be changed:

           

          The following entry in conf/server.xml needs to be changed from:

           

              <Connector port="9000" protocol="HTTP/1.1" URIEncoding="UTF-8"

                         disableUploadTimeout="true" connectionTimeout="20000"

                         acceptCount="100" redirectPort="8443" enableLookups="false"

                         maxSpareThreads="75" minSpareThreads="25"

                         maxThreads="150" maxHttpHeaderSize="8192"/>

           

          to reflect:

           

              <Connector port="9000" protocol="org.apache.coyote.http11.Http11NioProtocol" URIEncoding="UTF-8"

                         disableUploadTimeout="true" connectionTimeout="20000"

                         acceptCount="100" redirectPort="8443" enableLookups="false"

                         maxSpareThreads="75" minSpareThreads="25"  keystoreFile="C:/Users/Home/Directory/.keystore"

          keystorePass="changeit" scheme="https" secure="true" SSLEnabled="true" clientAuth="false" sslProtocol="TLS"

                         maxThreads="150" maxHttpHeaderSize="8192"/>