3 Replies Latest reply on Nov 17, 2011 9:12 AM by tzuriel

    Error in Switch Port Mapper

    tzuriel

      I am trying to run this tool on a stack of 3 3Com SuperStack 3 3870 48-port switches.  They appear as one large switch to Orion and SNMP works fine from the NPM gui and other tools (like the Bandwidth gauges).  However, the Switch Port Mapper errors out like this:

       

      Layer 2 Log Messages
      11/15/2011 11:11:58 AM - Testing credential...
      11/15/2011 11:11:58 AM - Getting sysObjectID...
      11/15/2011 11:11:58 AM - Getting sysUptime...
      11/15/2011 11:11:58 AM - Getting dot1q Bridge-MIB
      11/15/2011 11:12:27 AM - Getting dot1d Bridge-MIB
      11/15/2011 11:12:59 AM - Getting Port Table...
      11/15/2011 11:13:01 AM - Getting Interface Table...
      11/15/2011 11:13:13 AM - Unable to get requested table due to SNMP timeout

      11/15/2011 11:13:13 AM - Stopping collection message: Error getting interface table result: Error
      11/15/2011 11:13:13 AM - Error getting interface table


      Layer 3 log Messages
      11/15/2011 11:13:13 AM - Testing credentials...
      11/15/2011 11:13:14 AM - Downloading ARP Table...
      11/15/2011 11:13:25 AM - Complete

       

      Anyone experience this?  I have increased the SNMP timeout and that has made no difference.

       

      Thanks!

       

      Tzuriel

        • Re: Error in Switch Port Mapper
          Nandish

          Could you open a support ticket to look in further?Also post back the ticket number with the solution.

            • Re: Error in Switch Port Mapper
              tzuriel

              Case #287274 has been opened

                • Re: Error in Switch Port Mapper
                  tzuriel

                  The solution from Tech Support was:

                  First off, the error that you are getting specifically relates to the SNMP timing out. This is something that happens with the super stacks due to trying to pull to much from the device, and the IfTable causes a time out.

                  Here are a few things that you can try. First off, you can attempt to set it to ignoring trunk ports. You can do this from the switch port mapper settings.

                  Secondly, you can also disable the GET BULK from the settings. This will make the action take a lot longer, but has less chance of the time outs.

                  If that still does not work, then please attempt to use the MIB browser to see if you still get the time outs there.

                  Ignoring Trunk ports was already set in the tool but I unchecked the GET BULK setting and the mapping completed successfully.