6 Replies Latest reply on Jan 13, 2012 10:42 AM by Karlo.Zatylny

    SCOM MP query?

    newfads

      Hi All

      We are trying to install the SCOM SolarWinds MP 1.1, we get a list of the Devices\Switches etc to monitor (although we initially get an error about being unable to connect to the web services), we then exit the setup..but following this we never get any data in the console?  Ive checked the requirements... and the one query I have is what rights does the Orion User ID account need to have?

      Also our SolarWinds Admin replied with the below when I asked if they were running Orion 9.5...does this mean we running at the right level?

      "In Version Info most modules are at 2011.1, the SW Toolset is at 8.05.

       

      NPM is at 10.1.2"

      Kind Regards

      Andrew 

        • Re: SCOM MP query?
          Karlo.Zatylny

          Hi,

          Unfortunately, this is probably a case best handled by support.  We would need to look at the log files to determine what is going wrong or why the information is not being polled.  The versions of NPM reported by your SW admin are fine and will work with the SCOM MP.

          Thanks

          • Re: SCOM MP query?
            DanielleH

            Andrew-- when reporting this to support, would you also come back here and reference the case # and any solutions for the issue you are experiencing?

            Thanks!

            DH

              • Re: SCOM MP query?
                mezdem

                any update on the SCOM permissions? as I have tried various account permissons and still no nodes are showing in the scom config wizard..

                  • Re: SCOM MP query?
                    Karlo.Zatylny

                    If you are not getting data in the Configuration Wizard, then first check any communication issues.  Do you have a firewall blocking requests to your Orion server port 17777?  You also could create a special account for SCOM on your Orion server and use that for the requests.  After enabling DEBUG level logs for the Information Service v2, you could look in the Information log files to see if there are requests being made by that account.

                    If all else fails, open a ticket and support can help you get things set up properly.  

                      • Re: SCOM MP query?
                        mezdem

                        Thanks, I have posted in relation to the actual cause.. ports open and account is fine, having a sql error to do with nolock parameter..

                        2012-01-13 10:10:52,600 [6] ERROR SolarWinds.InformationService.Core.InformationService - Exception running query:
                        SELECT N.NodeID, N.Caption, N.IPAddress FROM Orion.Nodes (nolock=true) AS N RETURN XML RAW
                        2012-01-13 10:10:52,600 [6] ERROR SolarWinds.InformationService.Core.InformationService - Exception caught in method RunQuery
                        SolarWinds.Data.Query.ParserException: Unknown parameter(s) 'nolock' passed to Orion.Nodes

                          • Re: SCOM MP query?
                            Karlo.Zatylny

                            It appears that you are running the latest SCOM MP but not with NPM 10.2 or 10.2.1.  The latest SCOM MP requires one of those two versions as it takes advantage of SQL WITH NOLOCK for performance reasons.  Upgrade your NPM and you should be fine.