6 Replies Latest reply on Oct 10, 2011 1:35 PM by DanielleH

    %ctUM:PauseTime Problem

    daniel@web-pass.com

      I'm unable to get the %ctUM:PauseTime meta command to function correctly in a Device.Cli.Send Commands activity in CatTools 3.6.0.  CatTools is interpreting the "%ctUM:PauseTime 1" line as a command and sending it to the device.  Examining the device log confirms this.  Am I missing something syntactically?  Does whitespace matter?

      My activity:

      config t%ctCR
      snmp-server contact email "noc@webpass.net"%ctCR
      clock timezone -8%ctCR
      clock auto-correct-DST%ctCR
      sntp server 204.14.152.10 version 1%ctCR

      %ctUM:PauseTime 05

      exit
      write mem

      The switch received the command:
      TELNET:2> %ctUM:PauseTime 05

      The device is an Adtran Netvanta managed switch accessed via telnet.

        • Re: %ctUM:PauseTime Problem
          Steve Welsh

          Try removing the '0' from your command   %ctUM:PauseTime 05.

          I'm fairly sure that the whitespace is an issue but if the above doesn't work, try add a space between the ':' and 'PauseTime', just in case whitespace IS a problem.  

          I do know that you must get the case correct with all activity variable commands though, but you've got that right in your command, so that shouldn't be the problem.

          Please let me know how you get on.

          Steve

            • Re: %ctUM:PauseTime Problem
              daniel@web-pass.com

              Hey Steve,

              Thanks for the prompt reply.  I've tried just about every whitespace combination I can think of to no effect. Do the "Device Type" "Group" or "Model" device attributes have any effect on whether or not the activity variable gets correctly interpreted by CatTools?  In this example the "Device Type" is "Adtran.Netvanta.General", the "Group" and "Model" values are "Adtran Netvanta 1224"

              Thanks again for your help here.

              Daniel

                • Re: %ctUM:PauseTime Problem
                  Steve Welsh

                  Did you try the removal of the '0' from your command   %ctUM:PauseTime 05 suggestion too?

                    • Re: %ctUM:PauseTime Problem
                      daniel@web-pass.com

                      Yeah, that didn't seem to change anything.

                        • Re: %ctUM:PauseTime Problem
                          Steve Welsh

                          Did you manage to get this working?

                          I have ran a few tests here and it seems to be fine on my test systems using v3.6.0.

                          I tried with the %ctUM:PauseTime 5 and %ctUM:PauseTime 05 both were processed correctly.

                           

                          The only thing I did notice is that after each of your commands (prior to the PauseTime is used) you are explicitly sending a '%ctCR'.

                          CatTools will automatically send a CR at the end of each command (so long as in your command list, the next command appears on a new line).

                          You may therefore want to try removing the explicit %ctCR from the end of each of your commands (unless you really want to send a double CR?)

                          If you are still having issues with the %ctUM:PauseTime function, I'd recommend opening a support ticket so we can collect some logs from you to look into this issue in more details.

                           

                          Steve