3 Replies Latest reply on Sep 20, 2011 12:28 AM by Steve Welsh

    Failed to receive 'Begin' line in device config file

    alxpms

      Dear Tech-experts!

      Im having a really hard time to figure out the reason, why a particular cisco router running CatOS will produce a weird error message at kiwi backup.  When the daily backup will run automatically, kiwi keeps sending me (mail) the report with this error: Failed to receive 'Begin' line in device config file.  Furthermore it seems to be unable to identify any changes in the configuration but the configuration is properly taken as i checked, however each time the schedule runs it will mail me this message:

      Error with Schedule: Backup Configuration
      2011-09-08      "Cisco 6500"       "Failed to receive 'Begin' line in device config file"

      I already tried the following:  From a little research i did on this message, i figured out that has something to do with the time it takes to receive a response from the switch (unless im wrong).
      Therefore i went inside the scripts: C:\Program Files\CatTools2\Scripts and edited the following txt file Cisco.Switch.CatOS.txt

      I changed the time integer from 5 that it was previously to 30 since i thought that needed more time to get a response from the switch:

      RetVal = cl.WaitForMultData(Mult, Choices, cl.RecDataTimeOut * 30)
        Select Case RetVal
        Case 0
             BackupRunningConfig = "Failed to receive 'Begin' line in device config file"
             cl.Log 1, BackupRunningConfig
             Exit Function

      As you can guess it didnt work! Nothing happened and i still receive that error message.
      My appologies if this thread has been here before but i couldnt find anything by googling.
      Your help will be really appreciated...

        • Re: Failed to receive 'Begin' line in device config file
          Steve Welsh

          Hi,

          CatTools 2!!!  Wow, that's a blast from the past. :)   Have you tried installing the latest v3 release on a test system to evaluate the current Cisco.Switch.CatOS script to see if it works?   CatTools v2 is many years old now and chances are there may have been updates to the script since then.   You may want to check through the release notes:  http://www.kiwisyslog.com/option,com_changelog/Itemid,139/

          Finally, I just thought I'd check this with you too as it catches a few people out.

          The Cisco.Switch.CatOS switch is specifically for Cisco switches using the CatOS version of the operating system.  Some people think that this is the script they need for all Cisco Catalyst switches - even those using IOS - which is wrong.

          If your switch uses IOS, then you should be using the Cisco.Switch.IOS script instead.

          Regards,

          Steve

            • Re: Failed to receive 'Begin' line in device config file
              alxpms

              Thank you Steve for your fast response and your assist.  As i think of it you are correct about the version of CatTools 2 being obsolete and thats the way i think i will follow in order to solve my problems.  Only reason i kept it was my quite flat-single minded idea of "when something works-DONT touch it"... But keeping updated is far more important at the end.  However, as for choosing the proper Cisco device type i have already tried both IOS and CatOS even though my Switch is indeed running CatOs but nothing seems to work :(

              Best Regards
              Alex