6 Replies Latest reply on Sep 21, 2012 6:58 PM by Steve Welsh

    Unable to back up Nexus 7010 Switch

    suramach

      Hi,

      We are running KiwiCat Tool Ver-3.6.0. The software does not back up Cisco Nexus 7010 switch. I am getting following error in the log:

      Did not receive command prompt after connecting with SSH

      Login to Switch 7010 failed.

       

      What I noticed was Nexus switch takes few seconds to display the prompt when I ssh into it. May be this delay is causing KiwiCat to fail. This problem is not seen with Cisco Catalyst switches. Please help.

       

      -Ram

       

        • Re: Unable to back up Nexus 7010 Switch
          Steve Welsh

          Hi Ram,

          Did you manage to resolve this issue?

          If not, then please raise a support ticket so we can gather some diagnostic information from you with regards to this device.

          I think you may well be on the right track with regards to the delay before the prompt is shown being the issue.

          Regards,

          Steve

          • Re: Unable to back up Nexus 7010 Switch
            jwm.jmoore

            I had the same issue, running 3.5.

            I wound up getting it working by using the Cisco.Router.General template rather than the NXOS one.

            • Re: Unable to back up Nexus 7010 Switch
              mziegler

              Is anyone still having issues with this? I still can not get this to work for us and get the error login failed. I am using Kiwi Cat Tools 3.3.4 and all our switches are working great excpet our nexus 7010. I am using the cisco.router.general temp. and have tried all the other option with not luck. Right now I am tring telnet and know that the username and passwords are right but still get the same login failed. Any pointers or help?

                • Re: Unable to back up Nexus 7010 Switch
                  Steve Welsh

                  There was a modification to the Cisco.NXOS device script in CatTools v3.7.0 for an issue post SSH authentication which 'may' be related to the problem you are having.

                   

                  The fix was specific to scenarios where SSH credentials were used to establish a secure connection, but then no further (local) device authentication was required to access the device.  However because the banner contained somewhere in it the text 'login:' (for example  'Last login:' ), it fools CatTools to send a username which causes the secondary authentication routine to timeout.

                   

                  If this sounds like the scenario you have then 3.7.0 should fix this problem.

                  You then just need to ensure you disable the 'Initial loging requires password:' and 'Initial login requires username/password:' options in the device setup 'Passwords' tab.

                   

                  My recommendation would be to download the latest CatTools release as evaluation and install on a test system to see if it works.

                   

                  Hope this helps.

                   

                  Regards,

                   

                  Steve