4 Replies Latest reply on Aug 29, 2011 10:47 AM by dclick

    Full SNMP v3 compatibility

    dclick

      I have been using the engineers toolkit off and on for a few years. (currently, I have v10.7.0.103)  Recently, we have started working on migrating to SNMP v3 for all our devices.  Since we normally use the Orion NPM to manage the network, it really hasnt been as painful as it could be - there are still issues with SNMP v3 and alerting - but I digress.

       

      Today, I needed to setup a couple of interface monitors on a specific port on a specific switch.  Now, with SNMP v2, its a no brainer. BUT - since we are migrating to SNMP v3, the tool seems to not want to work.  I had to re-enable snmp v2c on this switch to watch this interface.

      My question is this - Does the Engineers toolkit FULLY support SNMP v3, or did I do something incorrect here?  If we dont have full support, when will this be 100% implemented?

      Since v2c (and v1 for that matter) have so many security holes, I am amazed at how many products STILL dont support it.

        • Re: Full SNMP v3 compatibility
          SteveSW

          dclick,

          The Engineer's Toolset is made up of a number of tools. Most tools fully support SNMPv3 and all gadgets in Workspace Studio support SNMPv3. Some classic tools are still being migrated over. For most of those tools you can get the same information out of Workspace Studio.

          Which tool did you have a problem with?

          --

          Steve

            • Re: Full SNMP v3 compatibility
              dclick

              I was creating an interface chart to watch a particular ports errors/discards.  With SNMPv3, I wasnt able to pull the interfaces. When I switched it to v2c, it worked like a champ.

              (Workspace studio, gadgets, interface table)

                • Re: Full SNMP v3 compatibility
                  SteveSW

                  dclick,

                  The interface table gadget in Workspace Studio should absolutely fully support SNMPv3. Make sure that your security on your device allows access to those interfaces. You may need to set up a group or view to provide access. Also, make sure you get the latest hotfix for Toolset from the website as it contains a fix for interface discovery.

                  If the hotfix and verifying the device's group and view configuration don't fix the issue open up a ticket with support and reference this thread.

                  --HTH

                  Steve