6 Replies Latest reply on Jul 31, 2011 11:07 PM by Steve Welsh

    No Polling Job for some of my switches

    smcdonald

      Hi All,
      I'm seeing some weirdness with the polling - several of my switches just arn't discovering MAC addresses at all.  When I check the UDT Status I can't see any polling jobs (neither Polling or Layer3).  I couldn't seem to find any way to remove and re-add the device to see if it created the polling job - I tried unmanage/remanage on the device and also tried unmonitoring the ports and remonitoring - no luck.
      The switches concerned are all Cisco 6509E with sup32 running IOS or 6513 running CatOS/IOS hybrid.  I do have other switches which are basically identical which are working correctly (and are running the same os versions/hw).
      Any ideas on how I can get this fixed?  I dont want to delete the device entirely since that remvoes the NPM object and I'd lose all my data on them.

      Also - does anyone know how the "hostname" field gets populated?  When I look at port history I only ever have MAC and IP listed (although a search will find the hostname).
      Thanks, Sean

        • Re: No Polling Job for some of my switches
          mavturner

          Sean, we have a service release RC available (1.0.1) that I will send to you offline that should help with some of these issues. In the service release you can delete nodes just from UDT and some of the polling issues were fixed as well. 

          Which port history resource are you talking about specificaly? Does it look like it's not being matched up to the IP/MAC? We resolve hostname by standard windows name resolution on the server.

          Mav

            • Re: No Polling Job for some of my switches
              smcdonald

              Thanks for that Mav, got it installed now and things are looking better.  I also noticed that I hadn't installed the Poller version on my poller either and I suspect that's why some switches didn't have pollers - doh.

              I still don't see DNS names resolving though under Port History - I *can* search using the DNS name and it finds the port - but when I look at the port details - under history theres no hostname listed - just MAC and IP.  I do see though that on the same switch - if I look at the Port Details for the entire switch it DOES show DNS names.  Seems the lack of the DNS name showing in Port History maybe related to why I can't use the watch list with a DNS name (MAC/IP works ok).

              I also note that the UDT Port Details isn't linked in any way to the actual port I'm monitoring in NPM (while the actual node is) - I'd like to be able to add the Port Details and History to the NPM monitored interface (so I can see everything in one place) but I can't see anyway to do it - is there method I'm missing?

              Thanks, Sean