4 Replies Latest reply on Jun 16, 2011 2:36 AM by jonesy5090

    Missing Right hand Column in Views

    jonesy5090

      Hi all,

      One of our users has been customising views which resulted in me having to restore the web site configuration using the overwrite option.  Everything seemed to be back to default, however the right hand column in the 'Top 10' view and the 'Problems' view doesn't contain any content.  I'm weary about just adding the content back in manually as I don't know what else has been affected.

      Is there a way to force the default settings to be restored?

      Thanks,

      Gareth.

        • Re: Missing Right hand Column in Views
          jonesy5090

          The plot thickens..... looking at the DB the resources table doesn't contain the resources that should be part of the view.... here's an example for the top10 list:

          ResourceID

          ViewID

          ViewColumn

          Position

          ResourceName

          ResourceFile

          ResourceTitle

          ResourceSubTitle

          1059

          147

          1

          1

          Top XX   Nodes by Current Response Time

          /Orion/NetPerfMon/Resources/TopXX/ResponseTimeTopXX.ascx  

          Top XX   Nodes by Current Response Time

           

          1060

          147

          1

          2

          Top XX   Nodes by Percent Packet Loss

          /Orion/NetPerfMon/Resources/TopXX/PercentLossTopXX.ascx  

          Top XX   Nodes by Percent Packet Loss

           

          1061

          147

          1

          3

          Top XX   Nodes by CPU Load

          /Orion/NetPerfMon/Resources/TopXX/CPULoadTopXX.ascx  

          Top XX   Nodes by CPU Load

           

          1062

          147

          1

          4

          Top XX   Nodes by Percent Memory Used

          /Orion/NetPerfMon/Resources/TopXX/MemoryUtilTopXX.ascx  

          Top XX   Nodes by Percent Memory Used

           

          1063

          147

          1

          5

          Top XX   Volumes by Disk Space Used

          /Orion/NetPerfMon/Resources/TopXX/DiskSpaceTopXX.ascx  

          Top XX   Volumes by Disk Space Used

           

          1191

          147

          1

          6

          Top XX   Wireless APs by Clients Count

          /Orion/NPM/Resources/TopXX/WirelessAPClientsCountTopXX.ascx

          Top XX   Wireless APs by Clients Count

          1192

          147

          2

          5

          Top XX   Wireless Clients by Traffic

          /Orion/NPM/Resources/TopXX/WirelessClientsTrafficTopXX.ascx

          Top XX   Wireless Clients by Traffic

          As you can see there's only one item in the right hand column, is there any way of restoring the defaults for this table? Note that we have UDT installed as well so we need to make sure that the node view includes the UDT resources.

          Before anyone asks..... no we don't have a backup of the DB unfortunately this hasn't gone into production yet, it's taken a month to get it to this stage I don't fancy doing a re-build!

          Cheers, Gareth.

            • Re: Missing Right hand Column in Views
              jonesy5090

              Further details.... looking at the contents of the "NetPerfMon Initial Configuration.NPMWebBackup" file that's used to restore the views, the view for Current Top 10 Lists doesn't contain any of the resources in the right hand column which is reflected by the table above.  This looks like a bug in the web configuration backup/restore program.... I don't think I'm going to be able to restore the original settings without a new .NPMWebBackup file.

                        <View Title="Current Top 10 Lists" Type="Summary" Columns="2" ColumnWidth1="400" ColumnWidth2="600" ColumnWidth3="500" System="FALSE" Customizable="FALSE">

                             <Resources>

                                  <Resource Name="Top XX Nodes by Current Response Time" Column="1" Position="1" File="/Orion/NetPerfMon/Resources/TopXX/ResponseTimeTopXX.ascx" Title="Top XX Nodes by Current Response Time" SubTitle="">

                                       <Properties/>

                                  </Resource>

                                  <Resource Name="Top XX Nodes by Percent Packet Loss" Column="1" Position="2" File="/Orion/NetPerfMon/Resources/TopXX/PercentLossTopXX.ascx" Title="Top XX Nodes by Percent Packet Loss" SubTitle="">

                                       <Properties/>

                                  </Resource>

                                  <Resource Name="Top XX Nodes by CPU Load" Column="1" Position="3" File="/Orion/NetPerfMon/Resources/TopXX/CPULoadTopXX.ascx" Title="Top XX Nodes by CPU Load" SubTitle="">

                                       <Properties/>

                                  </Resource>

                                  <Resource Name="Top XX Nodes by Percent Memory Used" Column="1" Position="4" File="/Orion/NetPerfMon/Resources/TopXX/MemoryUtilTopXX.ascx" Title="Top XX Nodes by Percent Memory Used" SubTitle="">

                                       <Properties/>

                                  </Resource>

                                  <Resource Name="Top XX Volumes by Disk Space Used" Column="1" Position="5" File="/Orion/NetPerfMon/Resources/TopXX/DiskSpaceTopXX.ascx" Title="Top XX Volumes by Disk Space Used" SubTitle="">

                                       <Properties/>

                                  </Resource>

                             </Resources>

                        </View>

                • Re: Missing Right hand Column in Views

                  Gareth--

                  If you don't hear back from the community soon, open a support ticket. When you open a support ticket, could you:

                  --Reference this thread to Support.
                  --Post back here with a case number.
                  --Post any solutions you get from Support.


                  Many thx,

                  M

                    • Re: Missing Right hand Column in Views
                      jonesy5090

                      I raised a ticket: Case #250699.  Support told me I had to start with a new database, I dropped the Resources, Views and ViewsByDeviceType tables from the old database and ran a SELECT * INTO oldTableName FROM newTableName to restore them back into the old database, at first it seemed to have worked but the interface view's all show the same graph 4 times.

                      It looks as though I'm going to have to start from scratch.....