9 Replies Latest reply on Jun 17, 2011 9:26 AM by MCMurphy

    SNMP info Test fails trying to add a node

    MCMurphy

      Evaluating UDT.  It has added all the 7 switches I've tried so far, even the ancient 3com 3300XM's.  This one is a way newer 3com 3CDSG8 switch.  I define and Test, get back "test failed".  I hit Next instead of Test and it says "Node does not respond with the supplied read/write community string".  It's the other side of my firewall, but I think I have the filters defined.  I run Wireshark on the UDT server, I see the Get-request going out and the Get-response coming back.  Both with SNMP v2c.  Last of the outgoing request is this:

      SNMPV2-MIB::sysobjectID.0 (1.3.6.1.2.1.1.2.0): unspecified

      and of the incoming response is this:

      SNMPV2-MIB::sysobjectID.0 (1.3.6.1.2.1.1.2.0): 1.3.6.1.4.1.43.1.8.69 (SNMPV2-SMI::enterprises.43.1.8.69)

      nd along the way the response includes a community: swudt which is what I've defined.  They seem to be talking, but not understanding.  Any ideas?

        • Re: SNMP info Test fails trying to add a node
          MCMurphy

          The node is sending back get-response, but a deeper look turns up a warning in one of the responses with these lines:

          error-status: no such name

          the value must be in primitive encoding

          BER error: Length:53 longer than tvb_remaining:48

          message: BER error length

          So I guess my node doesn't like something about some of what it gets from my UDT

          Any suggestions?

            • Re: SNMP info Test fails trying to add a node
              Steve Welsh

              Hi MCMurphy -

              In your original post, you mentioned about hitting the 'Test' button.

              I just would like to verify that this is the Test button you see on the 'Define Node' tab of the 'Add Node' wizard - correct?

              Regards,

              Steve

                • Re: SNMP info Test fails trying to add a node
                  MCMurphy

                  yes, the Define Node tab.  I put in the IP, leave ICMP and External unchecked, SNMPV2c, 161, put in communty string.  If I press Test it says "Test failed".  If I press Next it says "node does not reply with the supplied read/write community string".  Either way I get the same sequence in the packet trace, including the mesage about the malformed packet.

                    • Re: SNMP info Test fails trying to add a node
                      mavturner

                      MCMurphy,

                      What version of code are you running on the 3CDSG8? Maybe there is a bug with that device?

                      When you do a full walk of the device, does it show you other OIDs or do they all return with unspecified?

                      Mav

                        • Re: SNMP info Test fails trying to add a node
                          MCMurphy

                          I believe the swtich software is current.  I had to update once right after installing, but 3Com downloads lists that same version from April, 2009.  I did an snmpwalk to a text file, I can't say I undestand it all, but it lists out all sorts of info - here's some sample stuff:

                          iso.0.8802.1.1.2.1.3.8.1.6.1.4.63.171.86.157 = OID: SNMPv2-SMI::enterprises.43.1.8.69
                          SNMPv2-MIB::sysDescr.0 = STRING: 3Com 3CDSG8 - oc801_00_03
                          SNMPv2-MIB::sysObjectID.0 = OID: SNMPv2-SMI::enterprises.43.1.8.69
                          DISMAN-EVENT-MIB::sysUpTimeInstance = Timeticks: (978044400) 113 days, 4:47:24.00
                          SNMPv2-MIB::sysContact.0 = STRING: Mike Murphy
                          SNMPv2-MIB::sysName.0 = STRING: EXT 3CDSG8
                          SNMPv2-MIB::sysLocation.0 = STRING: NLK CR
                          SNMPv2-MIB::sysServices.0 = INTEGER: 3
                          IF-MIB::ifNumber.0 = INTEGER: 10
                          IF-MIB::ifIndex.1 = INTEGER: 1

                          I can paste the whole thing in here if that will be helpful; or upload it if there's a place for that.  It concudes with the line "End of MIB", which I take to mean no errors.  Thanks