13 Replies Latest reply on Jun 9, 2011 8:11 PM by Steve Welsh

    UDT polling load

    njoylif

      tweaking polls per sec to support UDT...

      doesn't look like existing system accounts for UDT.  I have set to recommended polls and still get the below banner

      and the link is <not found>.

      FYI

        • Re: UDT polling load
          jeff.stewart

          Larry,

          What do you have the UDT polling set at?  That link will work if you install the local help files.  They should have been included within the .zip download.

          Jeff

          1 of 1 people found this helpful
            • Re: UDT polling load
              njoylif

              gotcha, I'll install local help files.  did not do that. :)

              Polling set at default 30 min.

                • Re: UDT polling load
                  njoylif

                  ok. so that did it for the help files, but polling is still an issue.

                  I have set the poller intervals to the recommended settings on each engine.

                  thoughts?

                    • Re: UDT polling load
                      Steve Welsh

                      Changing the polling interval in the UDT Settings page sets the global polling interval with is used for all new switches and routers added to UDT after the settings change is made.

                      Existing switches and router will retain their original polling values.

                      If you need to change the existing switch and router polling intervals, you can do this via the Port Management page.

                      Set the 'Show' drop-down to 'Nodes', select the nodes you want to change the polling interval for then click the 'Edit Properties' button.  At the bottom of the edit properties page you should see the polling interval fields for UDT.  Changing these values will update all devices you have selected.

                      Regards,

                      Steve

                        • Re: UDT polling load
                          njoylif

                          great workaround.

                          my point is I have my "polls per second tuning" set to recommended and I'm getting this notice.  Is the tuner not set to account for UDT polls yet?  is there a rule of thumb to use to account for this?

                            • Re: UDT polling load
                              Steve Welsh

                              The 'Polls per second tuning' setting do not have any bearing on the UDT polling jobs, so changing the tuner settings won't help prevent the banner message "UDT jobs may not complete within the defined polling period".

                              Adjusting the UDT switch and router polling intervals (as you have done) is the correct way to go.

                              Regards,

                              Steve  

                                • Re: UDT polling load
                                  njoylif

                                  is this something you guys are working on?

                                  I set both routing and switch polling to 90 min and I'm still getting the message.

                                    • Re: UDT polling load
                                      mavturner

                                      Larry,

                                      What specifically are you asking about regarding what we are working on? We do hope to have a change where you can click "Update polling interval" so when you change the global, you can modify all of the existing intervals.

                                      The "UDT jobs may not complete ..." banner appears when you are polling too many ports on 1 server. In performance testing we saw that UDT can poll approximately 150,000 ports on a single server with the defaults polling intervals. How many ports are you monitoring?

                                      Mav

                                        • Re: UDT polling load
                                          njoylif

                                          just above 7000 total, but they should be spread across multiple pollers.
                                          I've changed the poll intervals for UDT to 180/180 and I'm still getting the banner.

                                          this is my concern about what you are working on :)

                                          So essentially, I should open a ticket?

                                            • Re: UDT polling load
                                              Steve Welsh

                                              Hi Larry,

                                              I apologize in advance for stating the obvious, but I'm presuming you clicked the 'Dismiss' button in the banner relating to this message?

                                              If so, then have you added additional devices to UDT since changing the polling intervals?  If you have, then can you verify that you also modified the 'Default Node Poll Interval' via the UDT Settings page which sets the polling interval for all switches and routers subsequently added to UDT?

                                              If not, then this may be a reason why the jobs are still reporting that they will take longer than the polling interval.

                                               

                                              The last thing to try would be a restart of the SolarWinds Orion Module Engine service via the Orion Service Manager (Start (button) > All Programs > SolarWinds Orion > Advanced Features).

                                              This will force a reload of all the UDT jobs again - just in case the new polling intervals haven't been picked up properly.

                                              Please let me know how you get on.

                                              Regards,

                                              Steve