4 Replies Latest reply on Mar 25, 2011 1:15 PM by michalB

    arp table from cisco pix

      Hi,

       

      I tried to get arp table from cisco pix as layer 3 device, but no luck.

      Log just shows this:

      Layer 3 log Messages
      17.03.2011 11:23:15 - Testing credentials...
      17.03.2011 11:23:15 - Downloading ARP Table...

      snmp is working fine.

      17.03.2011 11:44:57 - Connecting to <community-string>@test.example.com (10.10.10.10)...

      SysDescr: "Cisco Cisco PIX Security Appliance Version 8.0(4)28"

      Any possibility for me to get this working?

       

      tcpdump

        • Re: arp table from cisco pix
          michalB

          OID of the ARP table is 1.3.6.1.2.1.4.22. Can you check this is available on the device?

            • Re: arp table from cisco pix

              Hi Michal,

               

              many thanks for your answer.

              When trying to snmpget the oid I only get this:

              "IP-MIB::ipNetToMediaTable = No Such Object available on this agent at this OID"

               

              Any other suggestion?

              Maybe I should ask cisco guys too.

               

              Thanks in advance

              tcpdump

                • Re: arp table from cisco pix
                  SteveSW

                  tcpdump,

                  It looks like your device doesn't support the ipNetToMediaTable. This may be because it is older and needs updating or it is very new and the ipNetToMediaTable support has been removed in favor of the ipNetToPhysicalTable. Contact Cisco to find out for sure. Upgrading the Switch Port Mapper to support the ipNetToPhysicalTable is on our roadmap but I am not allowed by company policy to provide any dates for future releases.

                  --

                  Steve

                  • Re: arp table from cisco pix
                    michalB

                    The device may not provide the table. You should check that in the documentation for it. 

                    Switch Port Mapper allows you to set another device than the switch as layer 3 device. Have you tried that?