3 Replies Latest reply on Mar 21, 2011 6:47 AM by bmrad

    "Data Archive Window Exceeded" error on agents

    pixelgrunt

      Profiler Server 4.12.1

      Initially the agents were also running 4.12.1 on a mix of windows and linux, a few have been upgraded to 4.12.4 during troubleshooting.

      The referenced error would appear on the agents after some time and then all the important modules would stop working. The most important to us being the File Analysis module. All of our agents are set up to analyze NAS shares; we are not interested in running FA rules on any local storage of these agents. The windows agents were assigned the CIFS shares and the linux agents were assigned the NFS shares.

      I had a ticket open with solarwinds for the problem when it first appeared on the windows agents, and it was resloved by simply allocating more memory to the java process heap max. I tried the same resolution on the linux agents with no success so far.

      Has anyone else seen this problem? We have 2 independant networks and the problem appears on both.

        • Re: "Data Archive Window Exceeded" error on agents
          bmrad

          Generally you will see this issue when

          1) The Profiler server is having an issue collecting the data and the agent will start dropping the oldest data when it reaches is size limit (set per module).

          2) The data set is so large that the module reaches it size limit before the Profiler server can collect and remove the data.

          I would suggest you engage support to diagnose the issue a little further before you start changing your settings.

          Also, we generally recommend that the Profiler server always be at a version equal to or later to all agent versions.  In this case, you have a 4.12.1 server with 4.12.4 agents, so I would also recommend you plan to upgrade your server soon.  Note I don't think this would be causing the problem you are having, but its always better to have them at the same version.

          Brian

            • Re: "Data Archive Window Exceeded" error on agents
              pixelgrunt

              Thanks for the prompt response bmrad. I appreciate the insights.

               

              In the course of troubleshooting, I have updated the server to 4.12.4 as well as you suggested.

               

              I have gone through several cycles of uninstall/reinstalling the agents and changing the -Xmx flag value up to 4096M, and I still get the dreaded error, and all File Analysis data is gone from the server.

               

              As an attempt to address the memory usage, I reduced the number of network shares that are assigned to these linux agents. I still get the same failure.

               

              I am still engaging solarwinds support, and want to keep this thwack thread updated. If/when I get a resolution, I will try to post it here to help any one else who may experience similar problems.