2 Replies Latest reply on Mar 10, 2011 1:23 PM by jdk7400

    How to upgrade NPM 9.5 with additional poller

    jdk7400

      I am in the process of planning the upgrade of my Solarwinds system from 9.5.0 to 10.1.2.  I am struggling with one particular issue - I have 2 full pollers that report to the same database, which resides on a third server.  I realize this is not a supported setup but I inherited this configuration.  My plan is to change the second full poller to an additional poller sometime during the upgrade process (license already purchased).

      How should I go about this? 

      Scenario #1 - My initial thought was to uninstall everything from Poller2 and upgrade Poller1 and all other apps to the latest software then go back to Poller2 and install the additional poller software. If this is the recommended solution what is a quick, easy way to make sure all devices currently being polled by Poller2 are put back on Poller2 after the upgrade (I have 1200 devices that can only be polled by Poller2 and I have a maintenance window of 2 hours so manually moving them is not an option).  I am not very savvy with databases or scripting but I can follow instructions.

      Scenario #2 - Another option was to upgrade both servers at the same time.  This would alleviate my need to move devices from one poller to another but it introduces a new issue of how do you execute two upgrades at the same time without one stepping on the other.  Also, what is the process of performing the upgrade from full to additional poller - do I uninstall full poller or install the additional poller right on top of full poller?  Will the change from full to additional poller affect the engine ID and ultimately the devices associated with Poller2 in the database?

      Here is a quick overview of the servers/apps/databases that I have in my environment. 

      POLLER1
          -Windows Server 2003
          -full Poller license
          -Engine Version 9.5.0 - NPM 9.5 SP5
          -APM license (version 3.1.0)
          -reports to ORION_DB on DB-SERVER2

      POLLER2
          -Windows Server 2003
          -full Poller license
          -Engine Version 9.5.0 - NPM 9.5 SP5
          -reports to ORION_DB on DB-SERVER2

      SERVER-NCM
          -Windows Server 2003
          -Orion Network Configuration Manager 5.5.0
          -reports to NCM_DB on DB-SERVER1
          -Engineering Toolset,

      SERVER-WEB
          -Windows Server 2003
          -Orion NPM v9 Additional Web Server

      DB-SERVER1
          -VM Server
          -Windows Server 2003
          -Microsoft SQL Server 2005
          -NCM_DB

      DB-SERVER2
          -Windows Server 2003
          -Microsoft SQL Server 2005
          -ORION_DB

        • Re: How to upgrade NPM 9.5 with additional poller
          bshopp

          POLLER1
              -Windows Server 2003
              -full Poller license
              -Engine Version 9.5.0 - NPM 9.5 SP5
              -APM license (version 3.1.0)
              -reports to ORION_DB on DB-SERVER2

          POLLER2
              -Windows Server 2003
              -full Poller license
              -Engine Version 9.5.0 - NPM 9.5 SP5
              -reports to ORION_DB on CHMS-ORION

          Are both the these Orion installs pointing to different database instances?  You reference two different servers the DB resides on