16 Replies Latest reply on May 26, 2011 1:15 PM by joeygartin

    Export to PDF fail - 401 error

    BryanBecker

      Running 10.1.1 SP1 and nothing I try with exporting to pdf works.   I get the same error.  I have a case open (212529) but still waiting to work with tech support.

      Hoping someone else ran into this and got it working.

      B

        • Re: Export to PDF fail - 401 error
          bshopp

          Hey Bryan,

          Do you have the Orion website setup to use HTTPS?  Do you have a load balancer sitting in front of the Orion server?

          • Re: Export to PDF fail - 401 error
            Questionario

            Hi Bryan,

            I read somewhere in this forum before that this error also happens if you run HTTPS and the certificate is only issued to the website name and not the actual hostname. (e.g. you have a certificate for orion.yourcompany.com which works fine if you visit the website but the actual hostname of the server would be newyorkorionserver.yourdomain, in this case the certificate needs to be issued to both names unless solarwinds finds a workaround for this).

            • Re: Export to PDF fail - 401 error

              We resolved the problem by removing the IUSR_SERVERNAME user from the local Guests group and adding it to the local Users group.  Under local security policy, the local Guests group was Denied Access to the Computer via the Network.  Technical Support indicated the Export to PDF function uses IIS Anonymous Access.

                • Re: Export to PDF fail - 401 error
                  mr.e

                  I tried this, but it did not resolve the problem for us.  Still, I thought that this should work, since it work for the others in this posting thread.  I was able to get the problem resolved, by doing the following after the action listed above:

                  1.) Restart the IIS services

                  2.) From the Orion Service Manager window, click on the SolarWinds NetPerfMon item (under IIS Web Sites) and click Restart button.

                  Now, to be honest, I think that step #2 was an overkill, since the IIS restart should've been suffice.  Still, it took very little time and and it did resolve the problem.  I am now able to get PDF files from our Orion website.

                  By the way, I think it is true that this is a Windows 2003 issue.  We purchased an SL2500 license, which we use for testing and development on our Orion NPM server, whicih is a Windows 2008 R2 server.  The PDF problems that showed up on our Windows 2003 server never surfaced on the Win2008 box. 

                  Lastly, many thanks to y'all for sharing the fix about the IUSR_SERVERNAME.  We had announced the PDF feature to our users and they were disappointed when they could not use it.  We are now being called "heroes" again... at least for today....  :-)

                    • Re: Export to PDF fail - 401 error
                      henrymartens

                      Thanks for info guys.  Worked a treat!

                      Here's a quick recap for other's with a windows 2003 box:

                      1. remove the IUSR_SERVERNAME user account from the local Guests group

                      2. add the IUSR_SERVERNAME user account to the local Users group

                      3. restart the IIS Service.  worked straight away.

                      cheers!

                        • Re: Export to PDF fail - 401 error
                          joeygartin

                          I am running:

                          SolarWinds Orion Core 2011.1.0 SP1, APM 4.0.2 SP3, NPM 10.1.2 SP1, NTA 3.7, IVIM 1.1.1

                          On Windows 2003 Server

                          My IUSR_SERVERNAME was a member of the Users Group (which I take is the Local Users, as there is no other group with Users in the name) and I went ahead and removed them and re-added them to the group.  I also restarted the IIS service and the World Wide Web Publishing service.

                          I still get the same popup error (with IE or FF) stating "There was an error trying to export the page to PDF, please try again later.  Export to PDF failed.  Err:  The remote server returned an error: (401) Unauthorized."

                          Is there another solution?