13 Replies Latest reply on Feb 22, 2012 12:49 PM by malengine

    NPM polling interval is applied but not effective.

    yahaboho

      Hi All,

       

      I have an issue with Orion NPM that is giving me headaches for a few weeks (I am using v10SP1, issue was the same with v9.5). 

      I have defined status polling interval to 60s for all my nodes, but I keep getting only one response time value every 3mn in the database.

       

      This is what I get when I do a request in the DB for a random node :

       

      SELECT PollInterval FROM Nodes where NodeID = 3100;

      60

       

      Select top 5 datetime from ResponseTime_Detail where NodeID = 3100 order by datetime desc;

      2010-12-29 23:03:31.997

      2010-12-29 23:00:31.997

      2010-12-29 22:57:17.000

      2010-12-29 22:54:15.000

      2010-12-29 22:51:18.000

       

      I can see in the database how it happens, but I cant explain it :

       1) At t=0, a poll is done. The "NextPoll" value for that node is changed to t+1mn.

       2) At t+1mn nothing happens.

       3) At t+2mn still nothing, but the "NextPoll" value is changed again to one minute in the future (so t+3mn)

       4) At t+3mn, the poll is done (and so on).

       

       Processor use on polling engine never go above 25%, and disk queue on DB server stays ridiculously low. Polling completion is over 99%.

       I have 6k6 "pollable" items (nodes, volumes, interfaces), which would require 6600/60=110 polls per second, and i use 186 pps (recommended values of pps tuner tool). 

       

       I dont know what to do anymore, I totally ran out of ideas... please help :s

       

       Yann

        • Re: NPM polling interval is applied but not effective.
          patriot

          Thats a good question and I was ready to provide an answer, but my answer does not seem to be working!

          Normally, if you change the node polling interval on the Polling Settings page of the Orion web console, then click on "Re-Apply Polling Intervals", the new polling interval should be written to the PollInterval field in the Nodes table of the database.

          However, I see that my polling interval values are not changing in the database.

          Why are the new polling intervals not reflected in the Nodes table, but they are on the website?

            • Re: NPM polling interval is applied but not effective.
              patriot

              Additional information.... I can change the Rediscovery Interval on the website and it will change the value listed in the Nodes table. I can also change the polling interval for interfaces and I see the new value in the Interfaces table as well.

              Right now, the PollInterval field in the nodes table will NOT change to the new value set on the web site.

              What gives?

                • Re: NPM polling interval is applied but not effective.
                  yahaboho

                  I had same thing in the past, the mistake I was doing is not submitting the new values before.

                  To change the default values, you must first submit it (at the bottom of the page) then you can re-apply it on objects.

                    • Re: NPM polling interval is applied but not effective.
                      patriot

                      Nope. Does nto work for me. No matter which order I click Submit or Re-apply buttons, the Polling Interval for nodes does not change in the Nodes table of the database.

                      SolarWinds? Open a ticket?

                        • Re: NPM polling interval is applied but not effective.

                          Hey patriot--

                          Do open a support ticket esp. if this is time critical.

                          M

                            • Re: NPM polling interval is applied but not effective.
                              yahaboho

                              Hi,

                              Sorry to say but it doesn't reply to my initial question. The 1mn polling interval *is* updated in my DB ("PollInterval" is updated to '60' in "Nodes" table), but polling engine doesn't respect it and keeps polling every 3mn.

                              Yann

                                • Re: NPM polling interval is applied but not effective.
                                  ssym

                                  Has this been addressed? 

                                  If I use the Polling Settings page of the Admin console to change the polling intervals and the polling statistics intervals, these settings appear to take, because if I exit and come back in the new settings are shown.

                                  However, if I then go to the managed nodes page of the admin console and edit the properties of a node, only the polling statistics interval that I recently changed is shown. The Node Status polling interval remains unchanged.

                                  Furthermore, even if I change this node status polling interval for this particular node, the new value is not used by Orion. I have changed the polling interval value in both places (polling settings and properties of a managed node) to the largest acceptable value (1200 seconds) and then started a WireShark capture and there are still a ton of SNMP messages emanating from the node.

                                  How can I turn off or at least reduce the frequency with which all devices are polled? Is there currently a way to do this that actually works? Thanks.

                                    • Re: NPM polling interval is applied but not effective.
                                      bshopp

                                      Should work just fine, I would recommend opening a support ticket to investigate.

                                      • Re: NPM polling interval is applied but not effective.
                                        malengine


                                        If I use the Polling Settings page of the Admin console to change the polling intervals and the polling statistics intervals, these settings appear to take, because if I exit and come back in the new settings are shown.

                                        However, if I then go to the managed nodes page of the admin console and edit the properties of a node, only the polling statistics interval that I recently changed is shown. The Node Status polling interval remains unchanged.

                                         



                                        I believe this is a "feature." If you want a custom polling interval that is smaller for high-priority nodes, Orion will oblige you.  But if you go in an decrease the default interval, this will not affect nodes that already poll more often. I had to select a subset of my nodes and edit properties, check the checkbox for polling, and this will populate with the defaults you have set up under Admin > Polling Settings. I also needed to change my polling engine to the primary or this request timed out after submission; I'm not certain if this is because the secondary is overworked or what.

                                         

                                        I have changed the polling interval value in both places (polling settings and properties of a managed node) to the largest acceptable value (1200 seconds) and then started a WireShark capture and there are still a ton of SNMP messages emanating from the node.
                                        .

                                        Be aware that modifying the polling frequency won't do bupkus about SNMP traps sent from the node: that's entirely determined by the set up on the node itself.