3 Replies Latest reply on Oct 27, 2010 9:30 PM by Steve Welsh

    Nortel 8600 - privilege mode

      Hi there,

      Have used this tool in Cisco gear and it works like a charm - have came accross a Nortel 8600 router in which I need to run two commands every hour but not able to get into privilege mode through a scheduled Activity added.

      How could I make it go into privilege mode?  For device info, all 'Passwords' are entered correctly and logging works with no problem - was able to see this on Info log.  Nortel provided privilege password and a shell password - either way I try on Activity added, by list of commands typed in or reading commands from file, by 'Enter commands in enable mode' ticked in or not selected - not able to get into privilege mode and run two commands through added Activity.

      Note that doing this manually works with no problem so no issue with incorrect credentials used - it will be the way CatTools treats 'enable mode' which I would say is different to how Nortel deals with privilege mode - any input out there that would be helpful?

      Thanks indeed.

        • Re: Nortel 8600 - privilege mode
          Steve Welsh

          Hi hopenhope,

          The Nortel.Switch.Ethernet device type in CatTools handles entering enable mode as follows:

          - Sends enable command to device

          - If 'Enter Username:' or 'Enter Password:' prompt is received from the device; CatTools will send either:

          1. a) the 'AAA Username' and 'AAA Password' field credentials if you have the 'Enable mode uses AAA username/password fields' option ticked in the device setup Passwords tab; or
          2. b) the 'Enable password:' field credentials.

          - Once the enable mode prompt hostname# is received, the activity continues.

          Hope this helps.  If not, please detail what you see for your device during a manual Telnet/SSH session.

          Regards,

          Steve

            • Re: Nortel 8600 - privilege mode

              Hi Spartacus,

              Thanks for the reply - I have tried all Nortel.* devices but none of them enter into privilege mode - I ended up creating a Custom Device file which worked like a charm - bit of reding documentation, variables, etc but all worked out at then end.

               

              Thanks for the input.

               

              Rgds,

              Christian.