6 Replies Latest reply on May 26, 2016 5:37 PM by kchoi@cff.org

    Netflow Error

      Hi,

      I have recently installed Cisco Nexus 1000v and configured Nexus to send Netflow data streams to my NTA but i keep getting the below error. The Interface ID also changes everytime i get an error. Traffic is definatley getting to the NTA but its rejected the stream due to the error below.

      Any Ideas

       

      NetFlow Receiver Service [Servername] is receiving a NetFlow data stream from an unmanaged interface on Cisco Nexus 1000v. The NetFlow data stream will be discarded. Please follow the link Cisco Nexus 1000v or use the Orion System Manager to add Interface '#58137' in order to process this NetFlow data stream.

      Thanks

        • Re: Netflow Error
          aLTeReGo

          Go to "Admin"  >  "NetFlow Settings"  > "NetFlow Sources" and uncheck any interfaces you don't want to want to receive NetFlow data. 

          • Re: Netflow Error

            Hello Provident_NWS,

            The interfaces sending NetFlow data need to be managed by NTA in order to be able to see the data. You can do this by following the link into the alert message or by using the "Manage Sources" button on Netflow Sources resource.

            Also we dont repeat the alert for one interface (even though there is probably planty of NetFlow traffic going from your NetFlow enabled router), so each message is per unique interface sending NetFlow data.

            Please let us know if this helsp or if you actualy have different problem (e.g. NetFlow enabled device seems to send NetFlow data from interfaces with nonexisting if indexes etc.)

              • Re: Netflow Error

                Once more from here - this problem is actualy caused by fact that the interface(s) is (are) not being managed by Orion at all, so you need to go to Orion settings, then Manage Nodes -> List resources and here select the interfaces that you want to manage.

                Regards
                Jan

                  • Re: Netflow Error

                    hi guys,

                    i already have the Cisco Nexus 1000v in orion and all interfaces are managed but i still get the error?

                    cheers

                      • Re: Netflow Error
                        GZhytar

                        Hi Provident_NWS,

                        I've seen such a situations before - it was caused by the fact that SNMP Interface indexes reported by router (and though stored in Orion database) are different from indexes, reported inside NetFlow flows.

                        Please open support ticket at https://www.solarwinds.com/support/ticket/ . This information is needed to investigate this asap:

                         - SNMP Walk from the device (this should allow us to investigate content of Interface MIBs)  :

                        Please download and install net-snmp from http://net-snmp.sourceforge.net/

                        You can download the Win32 binaries here: http://sourceforge.net/projects/net-snmp/files/net-snmp%20binaries/5.5-binaries/net-snmp-5.5.0-1.x86.exe/download

                        It doesn’t matter what machine do you install it on, as long as it reaches the device.

                        Run this command from “installation directory/bin/”: snmpwalk -v 2c -c public -O netU 127.0.0.1 1 > output.txt

                        (change the IP address and community string accordingly)

                         - NetFlow traffic capture e.g using free WireShark sniffer from www.wireshark.org  (this gives us actual interface indexes from NetFlow packets

                         - Collect SolarWinds diagnostics (this gives us interfaces information from orion's database)

                        thanks

                          • Re: Netflow Error
                            kchoi@cff.org

                            I have recently installed Nexus1000v, and have same problem. Is there anyone solved this issue? or it is still a problem. FYI, I installed manageengine Netflow Analyzer, but same thing. I can see the netflow packet when I do packet capturing from the destination, only thing is that it can't decipher the packets. Someone said that this is because of v9 template because it is not sending real data, but template. If you have any solution, please guide me. thanks.