7 Replies Latest reply on Jan 9, 2013 9:21 PM by mobilenow

    Multiple NIC and SNMP issues?

      We are using ipMonitor 10 to monitor about 400 servers right now. We are moving forward with a new backup system that runs on a separate network. To make this work we are installing a secondary NIC in all of our systems. On my ipMonitor box after I installed the secondary NIC I started getting SNMP failures on most systems. So my question is, is this normal?

      Setup:
      NIC Team: internal network (default gateway set)
      Secondary NIC: backup network  (no default gateway)

      We are registering DNS for both as well. I'm trying to determine if the second NIC/network caused the issue or if it was something else. Using a SNMP test utility it would fail as well. I have since disabled the secondary NIC and things seem ok, but I did have to restart a great many systems' SNMP service before they came back online.

      If it did cause the problem, is there a way to make ipMonitor only work via one of the connections? We aren't using Traps at all, just simple SNMP for things like drive space, CPU, etc.

      Thanks!

        • Re: Multiple NIC and SNMP issues?
          Brachus

          We are experiencing the exact same situation after migrating ipMonitor 10.0.1 to a new server (W2k8R2).

          What is strange is the the old server (W2003)had multiple IP addresses on a single NIC and SNMP worked without any issues.

          THe issue appears whether we have mutiple ip addresses on a single NIC, or single addresses on multiple NICs.

          • Re: Multiple NIC and SNMP issues?
            Fodome

            Hello all,

            I worked on a similar case in November.

            Using a packet capture application, we determined that the SNMP queries were being sent via the second NIC as soon as it was added and no responses were being received from the remote devices.  As it is the Operating System that decides what NIC to use (and not ipMonitor) and as there were no responses being received when the packets were sent via the second NIC, it was determined that this was not an ipMonitor issue.

            My guess is that the IP of the second NIC could not be reached from the remote systems.  Unfortunately the client never responded back and I had to close the case.

            Having that said, I would suggest starting with a packet capture utility such as Wireshark in order to determine how the SNMP packets are being sent and if responses are coming back.  Then, take the troubleshooting steps needed based on the results.

            Hope this helps someone.

            Sincerely,
             
            Chris Foley - SolarWinds - Support Specialist
            Support:866.530.8040 || Fax:512.857.0125
            network management simplified  |  solarwinds.com

              • Re: Multiple NIC and SNMP issues?

                Thank you very much for this suggestion.  I ran Wireshark on our ipMonitor server and then started a device scan.  Looking through the Wireshark capture, it turned out that the SNMP packets weren't being sent out from the 2nd NIC, but from a secondary IP address on the 1st NIC that I wasn't aware someone had added.  After allowing SNMP packets from the secondary IP address on a test server, I was able to successfully scan that server from ipMonitor using SNMP.

                Thanks again!

              • Re: Multiple NIC and SNMP issues?
                McGregorKLB

                Hi guys, I see this is an old post but I still have a question about SNMP with multiple NIC's.

                 

                I have 1 Server with 5NIC's all running static IP addressees. Adding the system to Orion, I needed to figure out witch IP address would respond on the SNMP Community String.
                Once added to the Orion database the machine showed all the graphs I need. But.. when I rebooted the machine, Orion did not get any more SNMP data from the machine, only ping.

                 

                So.. the responding IP address for SNMP was changed (Interface or IP picked by Windows I guess).
                Once I changed the IP address in Orion NPM, I received all readouts again.
                I gave the machine another reboot to see if it would change again, and it did.. so now my question...

                 

                Can I bind the SNMP polling only to 1 interface and/or IP address ?

                 

                Hope I was clear enough. Thanks guys!!