6 Replies Latest reply on Jul 9, 2010 6:38 AM by HolyGuacamole

    New user of Profiler

      Hi,

      I just installed Profiler for Storage and Server to monitor an linux agent. This is really new to me. I have read through the installation guide but it is still not working for me.

      The agent is installed successfully as I managed to start the agent using /usr/bin/profiler_agent start and it started fine. When i did a ps -ef | grep Profile it showed me the processes related to Profiler. After that, I found out that snmp is required. Hence I installed net-snmp and started it. I even did a basic configuration. I then moved the snmpd.conf to /usr/share/snmp. I tried with a snmpwalk and it produced a long list of output, seems rather correct to me.

       

      On my profiler server, I can log into the profiler console, the web-based GUI. I added a server agent manually and it fails to communicate with the agent. Under Event monitor, the description given is Agent not collecting data whereas the Suggested Action is Perform the following tets:

      1. Collector is running (collector i think is the agent in the RHEL server)

      2. Check the status by clicking on the traffic light symbol (this yields the message: Could not connect to the agent! Make sure that the agent is running)

      3. A license is assigned to the device and all its subagent. ( I am using the 30-day trial prodcut)

      What other methods can i check to find out what is wrong? I am totally lost. PLease help, thank you.

        • Re: New user of Profiler
          bmrad

          Hi

          Profiler does not require snmp be installed.

          On the agent, check the core.xml (in the install dir, generally /opt/Profiler_Agent) and make sure the IP addresses are those of the Profiler server (in the <destinations> and <allow> tags).

          If they are not, the agent will not self-register with the Profiler server, and will not allow communication with the Profiler server (if you manually add the agent).

          If that does not work, I would suggest you contact support.

          Brian

          • Re: New user of Profiler
            HolyGuacamole

            Couple of things going on here.

            1. The agent should have registered automatically: Check the SNMP Trap Port in the Server section of the Server Setup page. If it has bound to a port other than 162, modify the /opt/Profiler_Agent/core.xml file to match the SNMP port and restart the agent

            2. Traffic light unable to connect to agent: Traffic light should connect even if you add the agent resource manually. Click on the traffic light again, and then tail the Kernel.log file under /opt/Profiler_Agent. It should log a message that it refused a HTTP request from ip/server name. Make sure the core.xml in the same directory has the ip/server name as seen in the Kernel log message and again restart the agent.

            Let us know if these steps make it work. If not, open a support ticket here

            http://www.solarwinds.com/support/ticket/ 

            and just provide "Solarwinds Profiler" as the customer id, and post the case id here. one of us will get in touch.

              • Re: New user of Profiler

                Hi Guacamole and bmrad,

                Thank you so much for your prompt response.  I looked into core.xml and modified the ip to the ip address of my profiler server. I do not see any trap port being mentioned in the core.xml but only the http port, which is similar to the http port specified in the  Profiler Server. Hence I didn't change that.

                After changing the IP address and restarting the profiler agent. I receive a fatal log with the entries below:

                FATAL ERROR ENCOUNTERED IN KERNEL ON Thu Jul 08 17:18:51 MYT 2010

                 

                Error Message:

                2

                Stack Trace:

                java.lang.ArrayIndexOutOfBoundsException: 2

                                 at com.tektools.kernel.trap.TrapService.<init>(TrapService.java)

                                 at com.tektools.kernel.Core.start(Core.java)

                                 at sun.reflect.NativeMethodAccessorsImpl.invoke0(Native Method)

                                 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

                                 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

                                 at java.lang.reflect.Method.invoke(Method.java:324)

                                 at com.tektools.kernel.Kernel.initialize(Kernel.java)

                                 at com.tektools.kernel.Kernel.access$200(Kernel.java)

                                 at java.lang.Thread.run(Thread.java:534)

                Total Memory: 16711680 bytes

                Free Memory: 14905336 bytes

                Threads Information [ Current THread: Kernel Thread]:

                com.tektools.kernel.Kernel$1[name=Kernel Thread Group,maxpri=10]

                     Thread[Kernel Thread,5,Kernel Thread Group]

                .

                .

                .

                .

                Kernel halted at Thu Jul 08 17:18:51 MYT 2010

                 

                Any idea what caused it to halt the agent start up? It is the same irregardless of whether my snmpd is running or not.

                  • Re: New user of Profiler
                    HolyGuacamole

                    Looks like something in the core.xml is not as per the expected format. A semicolon maybe missing in the <destinations> tag. A sample core.xml file is below.

                     

                       <?xml version="1.0" encoding="UTF-8" ?>
                     <configuration>
                     <kernel>
                      <core />
                      </kernel>
                     <service>
                     <trap>
                      <port>162</port>
                      <community>public</community>
                      <destinations>192.168.97.47:162:public</destinations>
                      <host>192.168.97.47</host>
                      </trap>
                     <http>
                      <maxuploadsize>104857600</maxuploadsize>
                      <allow>192.168.97.47</allow>
                      <port>4347</port>
                      </http>
                      </service>
                      </configuration>
                      • Re: New user of Profiler

                        Hi there Guacomle,

                        Geezz...thanks! now I manage to start the profiler agent and there is no longer a Fatal log. Now, when i tail the Kernel.log, I keep on seeing this message:

                        Attempting to send notification to "IP Of Profiler Server"

                        Call to PlceTrapOrder(1.3.6.1.4.1.10089.10090.10090) succeeded.

                        Unfortunately, I still do not see anything on my profiler console. Under Events of that resource, the summary shown is No text in varbindings, the short description says Agent not collecting data and the Trapname column shows agentNoResponse.

                        May I know what configurations have to be done on the profiler server? Under the wrench symbol of the resource, in the Communications portion, the configuration is as below:

                        Server: "IP of Profiler Server"

                        HTTP Port: 4319

                        Trap Destionation:

                        Server: "IP of Profiler Server"

                        Port: 162

                        Community: public (which is the same as the one configured in my agent)

                        Are the above correct?