8 Replies Latest reply on Jun 10, 2010 3:31 PM by ihatepcs

    Toolkit issues

      I'm kind of frustrated at the moment.  Yesterday I had a fit trying to get Toolkit installed and running.  Took a while - but I finally determined that the errors (trying to start workspace) were from a "corrupt" .net

      I ended up having to remove all versions of .net framework from the computer - reinstall.  Then Toolkit appeared to fine.  I used a bunch of tools yesterday.

      However - apparently my pc was set (as it should be) to download updates automatically - overnight several .net updates were installed and my pc was restared.  This morning I attempted to run toolkit (it started up ok) but the main tool im using right now - has been giving me fits.

      Now the nieghbor map tool is throwing all kinds of errors

      It works fine if i only use a "1" in the hop count - but if i leave it at 3 - forget it

      I have never in my life seen a program as finicky about .net as this one.

      after i dump all this .net framework off the system again - and reinstall - I'm gonna have to turn off the updates feature and that bothers me.  I should not have to run this on a "unpatched" system.

       

      when i run the neighbor map this the error it's throwing (and it didn't yesterday before the updates

      System.Collections.Generic.KeyNotFoundException: The given key was not present in the

      dictionary.
         at System.ThrowHelper.ThrowKeyNotFoundException()
         at System.Collections.Generic.Dictionary`2.get_Item(TKey key)
         at SolarWinds.Toolset.IEE.Tools.NeighborMap.NeighborMapControl.BuildMap()
         at System.Windows.Forms.Control.InvokeMarshaledCallbackDo(ThreadMethodEntry tme)
         at System.Windows.Forms.Control.InvokeMarshaledCallbackHelper(Object obj)
         at System.Threading.ExecutionContext.runTryCode(Object userData)
         at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode

      code, CleanupCode backoutCode, Object userData)
         at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext,

      ContextCallback callback, Object state)
         at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback

      callback, Object state)
         at System.Windows.Forms.Control.InvokeMarshaledCallback(ThreadMethodEntry tme)
         at System.Windows.Forms.Control.InvokeMarshaledCallbacks()

      ------------------

      i did remove the patches that were installed last night & rebooted. that didn't fix it.

      I don't know what else is "broken" i've really only used a few tools - and this one is important to me at the moment.

      any thoughts - besides stringing up a microsoft .net programmer?

        • Re: Toolkit issues

          I'm looking into the issue now; I'll contact you again once I have some more information.

            • Re: Toolkit issues

              as an update - i did remove .net framework 3.5  & 3.0

              restarted - and then removed 2.0 sp1 so the only .net was the 1.1

              i tried to start toolkit - and it complained that .net v2.0.50727 was not installed.

              restarted and reinstalled only 2.0 (no sp or patches)

              Toolset still starts fine - i still receive the same error running network map with 3 hops

              after i select continue from the error report - the map gadget appears to be "hung"

              Another symptom I noticed this morning - was yesterday when i used this with no problem - when i entered the ip address i wished to scan - the "messages/status" of what it was doing appeared below.

              Today from the very beginning - when i input the ip address and click the button - nothing appears  below - i actually have to left click on the gadget border to resize the window.  When i do that - i can see the messages.  When i release the button - it disappars.

              If it does display a map - that displays fine - it's just the messages while it scans that do this (if it doesn't crash out)

              I did change the video resolution to see if that would change this - no affect.

              This is a vostro 430  2gb ram  windows xp sp3 ati hd 4350 if that helps

                • Re: Toolkit issues
                  SteveSW

                  This sounds similar to an issue we fixed for 10.6. Can you try the 10.6 eval on that machine to see if it fixes your issue with the Neighbor Map gadget.

                  --HTH Steve

                    • Re: Toolkit issues

                      This was a new purchase (2 days ago)  I am running

                      10.6.0.84

                        • Re: Toolkit issues

                          Are you consistently getting the same crash using the same hop count and the same starting device(s)?

                            • Re: Toolkit issues

                              Well - here's what i did to further troubleshoot this

                              While i was waiting this afternoon - I found the .netcleanup utlity.

                              I removed using the utility all versions except 1.1

                              Restarted

                              Reinstalled 2.x

                              no sp/updates

                              at this point the map works -(still no status display while its scanning)

                              i have changed the hop count up and down - and so far no errors

                              I do not want to leave my computer in the state it's currently in (no updates/patches for .net)

                              and still no .net 3 or 3.5

                              Since it's almost time to go here now -

                              tomorrow I will start adding each one back one at a time to see if and where it fails (as time allows)

                                • Re: Toolkit issues

                                  OK, thanks.  If you're still having trouble with the crashes I definitely want to troubleshoot that further with you.  In the meantime, I'll take a look at the status message visibility thing that you mentioned.  Please keep me posted if you're still getting crashes.

                                    • Re: Toolkit issues

                                      Today i went and tried to do all the following updates for .net - and it is still not happy - some of the critical updates from microsoft fail.

                                      I really don't know what the deal is - but it is apparent that .net is just corrupted as heck.

                                      Everytime i restart the computer - i get a send report to microsoft window - (3 application crashes that were not reported at the time of the crash but can be manually reported)  And that would be true - i never get a box that says something crashed do i want to close or continue.

                                      All three are .net related - one of the three is swbrowserintegration.exe (which is a toolkit exe?)

                                      At this point I think the .net is so messed up with the installs/uninstalls/re-installs, unfortunately I will have to format the pc and start over.  I can't do that anytime soon, I may have to wait until after july 4, since i have just too many "pots in the fire".

                                      the toolkit (workspace) at least comes up and the few tools i need to use right now - seem to still work.

                                      When i wipe it i will make a point of doing all the .net sp and updates first - then reinstalling the toolkit before putting anything else on the pc.

                                      the whole .net framework has always given me a sour taste in my mouth, this just reinforces my reasons for it :-(