6 Replies Latest reply on Jun 8, 2011 8:03 AM by mgibson

    Custom SQL report fail with syntax errors for certain users.

    gbutler

      Anyone see this one?

      I have a sql report created that works fine.... for me and others, the person I created it for gets:

       

      Windows Server Drive Summary

      System.Data.SqlClient.SqlException: Incorrect syntax near the keyword 'WHERE'. Incorrect syntax near 'Nodes'. at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection) at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj) at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj) at System.Data.SqlClient.SqlDataReader.ConsumeMetaData() at System.Data.SqlClient.SqlDataReader.get_MetaData() at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString) at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async) at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result) at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method) at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior, String method) at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior) at SolarWinds.Orion.Common.SqlHelper.ExecuteReader(SqlCommand command) at SolarWinds.Orion.Web.Reporting.OrionReport.QueryData(String query, String orderBy, String grouping, String filter, Dictionary`2 macroContext) at SolarWinds.Orion.Web.Reporting.ReportRunner.WorkerProc()

      Now if its a syntax error you would think the error would fail for everyone... but this is not the case. I tried to identify any enviroment setting on the user by changing another user to match the one that errors... I was able to get him to fail but its not linked to any setting.  I say this because now that I backed  out of all the changes so that the user is back to were it once worked... it now fails.

      I never fails for me.  Other reports seem to work just fine for this user.   I'll open a support ticket and see but curious if anyone has experiances the same.

       

      Glenn.