9 Replies Latest reply on Apr 29, 2010 4:00 PM by Steve Welsh

    Nortel switch BS 450 and BS 470

      Hi!

      Is there a mean to backup config from Nortel BS450 and BS470? I don't know the fields to fill for these equipments (Enable password? AAA Password?) and what is the prompt? (Enter Password: ?)

      I've tried many solutions but I've always got this log: "Did not received expected response after sending password".

       

      Who has a solution to resolve this problem? I just want to backup a config from a bs450...

      Thx!

        • Re: Nortel switch BS 450 and BS 470
          Steve Welsh

          j-c,

          The Nortel 450's as far as I'm aware only has a Menu Driven interface.  The Nortel 470's start in Menu mode, but can switch to a conventional command line (CLI) mode.

          Try using the Nortel.Switch.NoCLI device type for the 450 and the Nortel.Switch.Ethernet for the 470.

          If your device only requires a password to authenticate; configure the 'Password' field only.

          If it requires Username/Password, then use the AAA Username and AAA Password fields instead.

          If you are using SSH to connect, then also configure the SSH Username and SSH Password fields.

           

          NOTE: the 450 only supports backup of its config via TFTP, therefore please use the Device.Backup.TFTP activity with the Nortel.Switch.NoCLI device type for the 450 backup.

          (a list of supported activities and reports per device can be found on-line here: http://www.kiwisyslog.com/wrapper/devices-supported/ )

          Hope this helps,

          Steve

          1 of 1 people found this helpful
            • Re: Nortel switch BS 450 and BS 470

              Hi!

              Thank you for these tips, it works very well on BS470. However, on BS450, there is a problem with the extensions of the configuration's filename: the script looks for .txt but the extension of the configuration's filename is .cfg (in my case). Is it possible to change this option in CatTools?

              Thanks,

              j-c

                • Re: Nortel switch BS 450 and BS 470
                  Steve Welsh

                  j-c

                  Is the .cfg extension being automatically appended by the device during the TFTP transfer, or did you include the .cfg file extension when you specified the filename in the activity options tab?

                  If you have set it in the options tab, try just specifying the filename without .cfg extension and see if this fixes it.  CatTools automatically appends a .txt file extension to the filename as it normally works fine like this.

                  Steve

                    • Re: Nortel switch BS 450 and BS 470

                      Steve,

                      I tried all these solutions:

                      - with .cfg file

                      - with .txt file

                      - without extension file

                      But I still have this problem (there is that log message: "Problem encountered sending Configuration Image Filename data"

                      Did you succeed to backup configuration with tftp on bs450?

                      Thanks for your help,

                      j-c

                        • Re: Nortel switch BS 450 and BS 470
                          Steve Welsh

                          j-c

                          The actual filename that gets used for the file uploaded to the TFTP server is the device filename, and not the value of the 'File to write to TFTP Server' field (sorry for misleading you on that one).

                          With the BS450 being a menu driven system, it actually works slightly differently to say Cisco IOS with this activity.

                          The 'File to write to TFTP Server' field is actually meaningless for the BS450, as we can only TFTP one type of config.  On Cisco IOS, you can specify which config you want to upload (e.g. running-config; startup-config, etc.) which is what the 'File to write to TFTP Server' field is intended for.

                           

                          The issue on your device is most likely either:

                           a) the device filename being provided as the TFTP file is not valid for the TFTP filename;
                           b) the device is taking longer than the (CatTools) default command execution timeout of 30 seconds;
                           c) the device is not returning the expected response.

                          You may like to try the following to test if the device filename is the issue:

                           1) Create a Device.CLI.Send Commands activity, associate just for the BS450.
                           2) In the Options tab, leave all the defaults ticked and use the following command list:

                          g
                          BS450Config.cfg   (you could use any other filename/extension you want, but try this as a test)
                          IP address of CatTools system   (i.e. enter the IP value for the CatTools system running the TFTP Server)
                          backup

                          The 'backup' command is an internal command for CatTools.  This command list was a workaround solution provided prior to the Device.Backup.TFTP activity was released, so customers could backup their 450's.

                          If this works, you should find a file in the \TFTP folder.

                          Next try swapping the BS450Config.cfg filename with the text %ctDeviceName.txt which will then tell CatTools to send the device filename.  Re-run the activity to see if this works. If it does, then its not an issue with the device filename.

                          If it fails, you may need to rename your device in CatTools to remove any unusual characters in order for the Device.Backup.TFTP activity to run.

                          Give this a try and let me know how it goes.

                          Steve