7 Replies Latest reply on Apr 8, 2010 11:27 AM by Nhicks

    New to NPM

    Nhicks

      Im setting up NPM for the first time after our trial, and have limited knowledge of SNMP.

       

      I have a RuggedCOM RS416 Serial terminal server, attached directly to my desktop via Ethernet running SolarWinds NPM.

      Desktop is 10.0.10.73   .0 subnet

      RS416 is 10.0.10.74   .0 subnet

      In NPM, I have the IP address (.74) added, SNMPv2c, port 161, community = public, RW = private

       

      On the RS416, there are 3 menus, Users, Groups and Access.  I have attached a PDF screenshot of the menus and my settings.

       

      So far everything I have tried results in a "test Failed" when I try Validate SNMP.  I have setup up Adtran routers in the same config, and they work fine.

       

      Any assistance would be greatly appreciated!!

        • Re: New to NPM
          Andy McBride

          The Rugged equipment is setting up SNMPv3, so you will need to add the devices to Orion as SNMPv3 also. Here is a paper on Implementing SNMPv3.

          Andy

            • Re: New to NPM
              Nhicks

              Thanks Andy.

               

              I tried to change the configs to V3, and that did not seem to change anything.  New PDF attached... can you find anything wrong?

                • Re: New to NPM
                  Andy McBride

                  A couple of suggestions -

                  • Check Allow 64 bit counters box
                  • get rid of the Read/write and test the Read only - We'll get one working then add the other.
                  • If that fails double check you device config
                  • Can you use MD5 rather than HMACMD5?
                  • Can you use DES rather than CBC DES?
                  • It almost looks like there is a space in the Orion trs1 user name. Probably just appears that way in the web page but check it just in case.

                  Andy

                    • Re: New to NPM
                      Nhicks

                      Andy - I thank you for your assistance.

                      I deleted the R/W part, and kept Read Only, checked the 64 bit counters, and verified the rts1 doesnt have a space.  No luck.

                      For grins, I set authentication to None, still no luck.

                      In the RuggedCOM - the only options are None/HMACMD5 and None/CBC-DES

                      For a "simple" protocol, its becoming quite frustrating!

                      New .PDF attached...

                        • Re: New to NPM
                          Andy McBride

                          Don't confuse Simple with Easy. ;)

                          Is it an option to use SNMPv2c for these devices?

                          BTW - If you had a Leno avatar I would have never offered to help. ;)

                            • Re: New to NPM
                              Nhicks

                              Yeah its not the same without him... long wait until August!

                              They will do V2c... I tried the same general concept.. I even tried basic V1, no luck.

                              I just put an Adtran 3205 router on this box with a 5 port hub/switch... configured it as V2c, it works great.  all 3 devices ping each other great.  But when I try to build the RuggedCOM with V2c, still no luck.

                                • Re: New to NPM
                                  Nhicks

                                  Well looks like I got it this time...

                                  After renaming some groups and trying different names, i finally got it to work.  At least on V2c.

                                  One of those things, I dont know what I changed, but something worked.  At least now I can use this as a baseline to get the others to work on the network.

                                   

                                  Thanks again for the assistance Andy.