6 Replies Latest reply on Apr 5, 2010 3:47 PM by travispbonfigli

    ip route-cache command missing (Cisco IOS 12.2)

      Hello All!

      I have looked around Google and the forums here with no luck and I am hoping that an expert out there might be able to assist me.  We are preparing to test SolarWinds out and I needed to configure NetFlow on our 7606 router.  I was following the instructions presented by the video at this link:

      http://www.solarwinds.com/geek/geekshorts/RTNA_how_to_Configure_NetFlow.aspx

      I ran the following commands which all worked and I had no problems at all:

      ip flow-export source gi2/15

      ip flow-export version 5

      ip flow-export destination 10.11.12.13  2055

      This is where the honeymoon ended :-)  Upon entering the interface mode to designate the interfaces I would like to capture NetFlow data for I attempted to run the following commands and it doesn't exist:

      ip flow ingress

      ip flow egress

      ip route-cache flow

      I ran the following "ip ?" to see what the problem was and the only options I have are the following:

      myrouter(config)#int gi2/4
      myrouter(config-if)#ip ?
      Interface IP configuration subcommands:
        access-group  Specify access control for packets
        address       Set the IP address of an interface
        arp           Configure ARP features
        dhcp          DHCP
        rsvp          RSVP interface commands
        rtp           RTP parameters
        vrf           VPN Routing/Forwarding parameters on the interface

      I am running the following IOS with the SUP720:

      Cisco Internetwork Operating System Software
      IOS (tm) s72033_rp Software (s72033_rp-PK9SV-M), Version 12.2(18)SXD4, RELEASE SOFTWARE (fc1)
      Technical Support: http://www.cisco.com/techsupport
      Copyright (c) 1986-2005 by cisco Systems, Inc.
      Compiled Tue 22-Mar-05 15:33 by yiyan
      Image text-base: 0x4002100C, data-base: 0x42318000

      ROM: System Bootstrap, Version 12.2(17r)S2, RELEASE SOFTWARE (fc1)
      BOOTLDR: s72033_rp Software (s72033_rp-PK9SV-M), Version 12.2(18)SXD4, RELEASE SOFTWARE (fc1)

      I looked all over the Cisco site (as I suspect it might have something to do with the IOS version) and don't see anything indicating that the IOS doesn't support NetFlow...has anyone else out there had this problem or do I need to upgrade to have the ability to configure NetFlow on each interface?  Thank you so much for your help!

       

      Cheers,

      Travis

        • Re: ip route-cache command missing (Cisco IOS 12.2)
          Donald_Francis

          The 7600 is not your typical router.  It's more closely related to a 6500 than a router.  They actually even share some blades.

           

          I think like a 6500 it has a RP and an SP and netflow working in hardware on different levels.

           

          Long story short look at the post for enabling it on a 6500 either here or cisco.

           

          http://www.cisco.com/en/US/docs/routers/7600/ios/12.2SXF/configuration/guide/nde.html

          • Re: ip route-cache command missing (Cisco IOS 12.2)

            Did you do a "no switchport" first? I don't think those commands work on switchports, need to be router ports.

              • Re: ip route-cache command missing (Cisco IOS 12.2)

                I knew it would be an Arsenal fan to post up the solution! :-)  First, let me thank everyone who responded!  Your support is GREATLY appreciated and this is what makes the Internet so great...people helping people!  I went ahead and tested on a port on the same 7606 Router which was NOT in use and did the following:

                router(config)#int gi2/14

                router(config-if)#no shut

                router(config-if)#ip ?

                Interface IP configuration subcommands:  access-group        Specify access control for packets  accounting          Enable IP accounting on this interface  address             Set the IP address of an interface  arp                 Configure ARP features  authentication      authentication subcommands  bandwidth-percent   Set EIGRP bandwidth limit  bgp                 BGP interface commands  broadcast-address   Set the broadcast address of an interface  cef                 Cisco Express Fowarding interface commands  cgmp                Enable/disable CGMP  dhcp                Configure DHCP parameters for this interface  directed-broadcast  Enable forwarding of directed broadcasts  dvmrp               DVMRP interface commands  flow                NetFlow related commands  hello-interval      Configures IP-EIGRP hello interval  helper-address      Specify a destination address for UDP broadcasts  hold-time           Configures IP-EIGRP hold time  igmp                IGMP interface commands  irdp                ICMP Router Discovery Protocol  load-sharing        Style of load sharing  local-proxy-arp     Enable local-proxy ARP  mask-reply          Enable sending ICMP Mask Reply messages  mobile              Mobile IP support  mrm                 Configure IP Multicast Routing Monitor tester  mroute-cache        Enable switching cache for incoming multicast packets  mtu                 Set IP Maximum Transmission Unit  multicast           IP multicast interface commands  nat                 NAT interface commands  nbar                Network-Based Application Recognition  nhrp                NHRP interface subcommands  ospf                OSPF interface commands  pim                 PIM interface commands  policy              Enable policy routing  probe               Enable HP Probe support  proxy-arp           Enable proxy ARP  rarp-server         Enable RARP server for static arp entries  redirects           Enable sending ICMP Redirect messages  rgmp                Enable/disable RGMP  rip                 Router Information Protocol  route-cache         Enable fast-switching cache for outgoing packets  router              IP router interface commands  rsvp                RSVP interface commands  rtp                 RTP parameters  sap                 Session Advertisement Protocol interface commands  security            DDN IP Security Option  split-horizon       Perform split horizon  summary-address     Perform address summarization  tcp                 TCP header compression parameters  unnumbered          Enable IP processing without an explicit address  unreachables        Enable sending ICMP Unreachable messages  urd                 Configure URL Rendezvousing  verify              Enable per packet validation  vrf                 VPN Routing/Forwarding parameters on the interface  wccp                WCCP interface commandsns03es7606-101xxxr34(config-if)#switchport

                router(config-if)#ip ?

                Interface IP configuration subcommands:  access-group  Specify access control for packets  address       Set the IP address of an interface  arp           Configure ARP features  dhcp          DHCP  rsvp          RSVP interface commands  rtp           RTP parameters  vrf           VPN Routing/Forwarding parameters on the interface

                router(config-if)#

                My only question then would be, is it not possible on a 7606 to get NetFlow going then if the port is a switchport and not a L3 port?  It looks like the answer is yes, but wondering if there is a workaround or if this is correct?

                That is it!!!  Again, thank you so much for the assistance!!!  And let's hope Man U gets beat at City and Chelsea slip up at Anfield...GO GUNNERS!!! :-)

                Cheers,

                Travis

              • Re: ip route-cache command missing (Cisco IOS 12.2)
                chuco

                Travis,

                     Have you tried 12.4 IOS yet?