2 Replies Latest reply on Sep 30, 2009 9:41 AM by auslaender6

    Login MCData Shpereon 4500

      Hi,

      I have problems to logon to the Shpereon 4500 Fibre Switch.

      I use the Type McData.Fibre and Model 4400.

      Info Log:

      2009-09-28 13:48:38 3-Info 0 Kiwi CatTools Service Performing activity - Run Now
      2009-09-28 13:48:38 3-Info 0 Kiwi CatTools Service Loading activity: McData_FC_Switche. Schd: 10
      2009-09-28 13:48:38 4-Debug 0 Kiwi CatTools Service Marshaller - Running script. Device: FC40MGMT02
      2009-09-28 13:48:41 4-Debug 1 FC40MGMT02 SSH Fingerprint: e1:7d:53:41:27:06:8c:20:87:e5:5d:64:c8:88:20:ce
      2009-09-28 13:48:41 4-Debug 1 FC40MGMT02 Connected to 10.242.5.2
      2009-09-28 13:48:41 4-Debug 1 FC40MGMT02 Login McData Fibre: FC40MGMT02
      2009-09-28 13:48:41 4-Debug 1 FC40MGMT02 Waiting for command prompt
      2009-09-28 13:48:41 4-Debug 1 FC40MGMT02 Sending login VTY password
      2009-09-28 13:48:41 1-Error 1 FC40MGMT02 Password is incorrect for device.
      2009-09-28 13:48:41 4-Debug 1 FC40MGMT02 Login to FC40MGMT02 failed
      2009-09-28 13:48:41 3-Info 0 Kiwi CatTools Service Stopping Activity.
      2009-09-28 13:48:41 3-Info 0 Kiwi CatTools Service All threads have finished. Now processing results...
      2009-09-28 13:48:41 4-Debug 0 Kiwi CatTools Service Writing sortable HTML report to: C:\Program Files\CatTools3\Reports\Device.CLI.Send commands.htm
      2009-09-28 13:48:42 3-Info 0 Kiwi CatTools Service Run Now activity has completed

      Debug Output:

      <NEWSESSION Kiwi CatTools 3.4.0 28.09.2009 13:39:44>
      <PROTOCOL=SSH2>
      <DEVICE TYPE=McData.Fibre>
      <ACTIVITY TYPE=Device.CLI.Send commands>
      <ACTIVITY SCRIPT=C:\Program Files\CatTools3\Scripts\Client.Device.CLI.Send commands.txt>
      <USERS NAME FOR DEVICE=FC40MGMT02>
      <C OK 13:39:46><R-13:39:46>******************************************************************************[13][10]* This login banner can be configured to adhere to your corporate security   *[13][10]* policies.                                                                  *[13][10]*                                                                            *[13][10]* Due to security concerns, default users will be prompted to change default *[13][10]* passwords upon login. To retain the default password, re-enter it at the   *[13][10]* Password: and Confirm: prompts.                                            *[13][10]*                                                                            *[13][10]******************************************************************************[13][10][13][10]<W-13:39:46>mYPassworD[13]<R-13:39:47>Password: <R-13:39:47>[13][10]<R-13:39:47>Root>

      This shows it's logged in (Root>) but CatTools always says password invalid.

      If you connect via putty, it looks like this:

      login as: Administrator
      ******************************************************************************
      * This login banner can be configured to adhere to your corporate security   *
      * policies.                                                                  *
      *                                                                            *
      * Due to security concerns, default users will be prompted to change default *
      * passwords upon login. To retain the default password, re-enter it at the   *
      * Password: and Confirm: prompts.                                            *
      *                                                                            *
      ******************************************************************************

      Password:

      Any suggestions?

        • Re: Login MCData Shpereon 4500
          Steve Welsh

          Hi,

          CatTools is failing to negotiate your McData Sphereon 4500 Fibre Switch password because your device banner also includes the text Password:.

          By default, when the prompt  Password:  is received CatTools will immediately send the password to attempt to authenticate.  What is happening on your device is CatTools is sending the password too early in response to the  Password:  text being found in your banner.  When your device then sends the real password prompt, CatTools reads this as a failed authentication attempt.

          The solution would therefore be one of the following:

          1) Change your device banner to something which excludes the Password:  text.   Maybe just set it instead to say 'Password' (without the ending ':' and wrapped within single quotation marks?).

          2) Alternatively, it seems from the device captures that your password prompt may also be returning a single whitespace character after the ':'.   If this is the case, then you may be able to set an override Password prompt in the Prompts tab of the device setup form in CatTools.  Set the VTY Prompt: field to Password:  (Note: including a single whitespace character at the end).  This will override the default in the script.    Finally so that CatTools can distinguish between this new override prompt and the banner text, wrap the Password:  text in the banner within single quotes ensuring that there is no whitespace between the ':' and the end quote (i.e.  'Password:' ).

          Please let me know how you get on.

          Regards,

          Steve