21 Replies Latest reply on Aug 7, 2017 10:01 AM by robertcbrowning

    Network Map Error

      Hi, we recently started having issues with our network maps...  Some maps, at random times (aka they rarely work), are generating the error

      Unexpected error: An error occurred while generating map  75205ddd-2a07-4677-8030-ffc2b391b7a2.OrionMap

      We were on 9.5sp1, and were getting an error with the entire C:\WINDOWS\TEMP\NetworkAtlas\Maps\Orion\localhost\[file] path.  We had reason to look through the maps last week, and they were working, previous to that, windows updates were done a week earlier.  After digging through google and some threads here, decided to upgrade to sp4, and now we're getting the above error (obviously with different filenames for different maps).  Any point in the right direction would be appreciated.

      Thanks,
      Chris
        • Re: Network Map Error
          bshopp

          I am looking into, however, have you opened a ticket with support?

            • Re: Network Map Error

              I realize this is an old post however, I am having this same issue and wonder if a fix has been found.

              My distinct issue is:

              When logged in as admin I see all maps

              When I create a new user (and grant all access) the map does not display and I get the Unexpected error: An error occurred while generating map 6f9249f1-224e-4fd4-863e-caa8cb4108da.OrionMap.

              I am using Orion NPM 10.1 on a Windows Server 2008 machine.

              Please let me know your thoughts because I am going to be rolling this out to the organization soon and need this functionality.

                • Re: Network Map Error
                  michalB

                  hi, this is a very general error message that can have many causes. Could you please contact our support?

                    • Re: Network Map Error

                      Is that even true if it just happens for the new user created and not the admin account? Just wondering before I call support.

                        • Re: Network Map Error
                          michalB

                          I have not seen such issue yet. Maybe support representatives did. Before you call support, you can check whether the user has some limitations, and if she does, whether you have any administrator's account without limitations active. There is nothing else I can recall right now that would be specific so much that it would work for one user and not for the other.

                      • Re: Network Map Error
                        Leon Adato

                        We have also started seeing this issue, and I am going to log a ticket as soon as I complete this post.

                        Our configuration is NPM 10.1.2 running on Windows 2008. We have a primary poller, additional poller and an additional web server all running behind a proxy server with SSL.

                        If I point to the website running on the primary polling engine, it all shows up.

                        I'll update this page when (not if, when) I get a resolution.

                         - Leon

                    • Re: Network Map Error
                      michalB

                      Please check whether the C:\Windows\temp directory is accessible for the IIS service (verify that the service has sufficient rights to write there). You may also try to delete the folder C:\Windows\temp\NetworkAtlas and then refresh the website.

                      If this does not help, I would suggest contacting our support.

                      Thank you,

                      Michal

                        • Re: Network Map Error

                          I've run in to this a couple of times now after various other glitches and the consistent and predictable solution does appear to be deleting the C:\WINDOWS\Temp\SolarWinds\NetworkAtlas folder.  This does not require any service restarts and has behaved well every time I have needed it.

                          • Re: Network Map Error
                            byrona

                            We are experiencing the map error noted in this thread on one of our two additional web servers.  Deleting the NetworkAtlas folder in the C:\Windows\temp\SolarWinds directory on the problematic web server did not seem to resolve the issue.

                            The map is working find on our other additional web server for some reason.

                            Any other pointers on how to solve this problem?

                              • Re: Network Map Error
                                michalB

                                Try this: change the identity of the website service to "Local System". If this works, there might be a problem with the policies set in your local network. Otherwise, contact our support.

                                  • Re: Network Map Error
                                    byrona

                                    Thanks!

                                    In addition I found that if I click on the Edit button for the map element I get the following error on that web server as well...

                                    Orion Website Error

                                    There was an error communicating with the Orion server.
                                    Additional Information
                                    There was no endpoint listening at net.tcp://localhost:17777/SolarWinds/InformationService/Orion/ssl that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.
                                    Troubleshooting Steps

                                       1. Confirm that the SolarWinds Orion Module Engine service is running, as shown in the following steps:
                                             1. Click Start > Administrative Tools > Services.
                                             2. Right-click SolarWinds Orion Module Engine, and then click Start.
                                       2. If the SolarWinds Orion Module Engine service is already running, contact SolarWinds Support.
                                       3. Refresh the Orion Web Console browser.
                                       4. If the Orion Web Console does not display, contact SolarWinds Support.

                                      • Re: Network Map Error
                                        pacetti

                                        byrona,

                                        This KB article may address the Orion Website Error you've encountered.

                                          • Re: Network Map Error
                                            byrona

                                            Thanks, I will try this out if after checking a few other things the problem doesn't get resolved.

                                            I certainly hope it doesn't have to come down to actually re-installing a service considering that this was working before.

                                              • Re: Network Map Error
                                                robertcbrowning

                                                Overnight we also lost the ability to see maps. The home map frame displayed the error

                                                "Unexpected error: An error occurred while generating map 843391e8-701f-468c-bb03-c94b533fd565.OrionMap"

                                                This only affected an additional web server while the primary poller continued to display maps and other information OK. Interestingly, reports that are displayed on the additional web server also failed to show.

                                                On the additional web server, I ran the Configuration Wizard selecting only the website. On completion it did not restart the website service, but I started it manually without problem. Both the maps and reports immediately displayed on our wall monitors.

                                                Have we got some sort of application housekeeping issue that needs addressing?

                                                Robert

                                                NPM9.5 SP4

                                      • Re: Network Map Error
                                        Damon Lohman

                                        This worked for me, thank you.

                                      • Re: Network Map Error
                                        Leon Adato

                                        Here's the process that worked for me:

                                        Add the following users...:

                                        • (local server, win2003) IIS_USERS
                                        • (local server, win2008r2) IIS_IUSRS
                                        • (local server) IUSR
                                        • (domain) Network Service
                                        • (domain) Authenticated Users

                                        ...to the following folders...:

                                        • c:\inetpub\solarwinds\
                                        • (win2003) c:\program files\solarwinds\orion\
                                        • (win2008R2) c:\program files (x86)\solarwinds\orion\
                                        • c:\windows\temp\
                                        • C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\
                                        • (in addition, on Windows 64-bit) C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\

                                        ... giving each user "Full Control"

                                        Next open

                                        • C:\WINDOWS\Temp\SolarWinds\NetworkAtlas\Maps\Orion\localhost\
                                        • (on my server, this was actually) C:\WINDOWS\Temp\SolarWinds\NetworkAtlas\Orion\Solarwinds\NetworkAtlass\MapsWeb\Orion\localhost\

                                        Clear out all files inside this folder to allow the website to re-write them.

                                        Restart your Information Services using the Orion Service Manager tool (under Advanced features in the start menu). Restart both of the information services - none of the other services need to be restarted.

                                        Restart IIS again from the Server Manager utility.

                                        Back on your browser, log out as the affected user, log back in and hit refresh - making sure to clear the cache (Shift-F5, Ctrl-F5, whatever).

                                          • Re: Network Map Error
                                            ecklerwr1

                                            My biggest problem with this is granting full control to things that don't necessarily need them... this may depend on the kind of environment you work in ie. a development one or not.  To me this is like turning part of your firewall off because you can't figure out why something doesn't work with port traffic.

                                             

                                            And yes now I'm getting this error with maps as well on NPM 10.3.1 SLX... in addition now I can only run Atlas from clients and not the main NPM Server.  Sometimes security is a pain... and so is NPM.   Don't get me wrong... I'm not sure what's at fault with my one of four NPM machines... could be a lot of things.

                                            • Re: Network Map Error
                                              cj_bergeron

                                              Worked for me, thanks.

                                            • Re: Network Map Error
                                              robertlkraft35

                                              I came across this problem in NPM after installing then removing the Engineer Toolset. I tried all of the above fixes but to no avail. On a last ditch effort I went to Control Panel > Programs and Features and then right clicked each Solarwinds product and selected repair. On refreshing the page the maps began to show up.

                                              • Re: Network Map Error
                                                robertcbrowning

                                                and also see

                                                Unexpected Error: An error occurred while generating map (map name).OrionMap

                                                This article addresses the issue where the Network Atlas Map is not displaying as a resource in Orion Summary or NPM Summary in the Orion Web Console. Sample error: Unexpected error: An error occurred while generating map c6bfa427-b9a2-45a2-95cc-f4d5656a36fd.OrionMap Diagnostic Logs: System.IO.IOException "The file exists"

                                                Network maps fail to load in Web Console with unexpected error while generating map

                                                What to do if you encounter the issue where Network maps fail to load in the web console with error:     Unexpected error: An error occurred while generating map 3be9a96b-2dcf-42f7-a7e2-4e295fdd8368.OrionMap