5 Replies Latest reply on Sep 1, 2009 2:13 PM by r0berth1

    SNMP Issue

    Mystic

      This isn't so much a Solarwinds NPM issue but I know it's an issue with a Switch that I have in production. I'm hoping that other engineer's out there have run into the same issue and maybe resolved the issue.

       

      I have one device that is running a realitivly new Cisco IOS. It's a Cisco 3750 Switch. I have it configured for both Snmpv2 and Snmp v3. I'm using NPM 9.1

      The configs and the IOS are exactly the same as the rest of the gear in production and we have over 200 devices being monitored by NPM. For some reason this device will NOT communicate with any monitoring tool using Snmpv2 or v3. Right now it's being monitored with ICMP only as I need to know if this device goes down so an alert will be triggered.

      I've been working with a Cisco Engineer for 3 weeks and no luck. They took my configs and tried to Lab it out and They have no issues.

      I ran into this issue with a 3550 a few months back on a non production switch. The only way i got it to work was to Downgrade the IOS to one i'm already using and then of course reboot.

      In this case I know there is NOTHING wrong with the IOS and i'm thinking the switch needs to be rebooted but this can't be done for this switch in the near future. It needs to stay up 24/7 and will be a pain to get change control approved to reboot.

      Anybody else have a similar problem where snmp will not commuicate with a 3rd party monitoring device? I even tried putting it on What's up Gold (our old monitoring device) to see if maybe it was an NPM issue but its not. Cisco is clueless at this point and don't know what else to do.