3 Replies Latest reply on Aug 21, 2009 9:31 AM by pkanai

    SNMP System Summary won't work with Fortinet firewalls

      I've been having trouble getting the activity 'Report.SNMP.System.summary working with multiple Fortinet firewalls. I have confirmed all my settings on the server running Cattools and the Fortinet firewalls I'm trying to get queries from. I see traffic reaching my firewalls from the CatTools program but my firewall doesn't respond.I have also tested another SNMP program from the same server to the same firewalls using the same settings and that has worked.

      Other functions within CatTools work great so I was hoping I could have some insight to what the script is doing and also any assistance I could get in this matter. I can post any data needed including debug data from the program.

      Thank you.

        • Re: SNMP System Summary won't work with Fortinet firewalls
          Steve Welsh

          The Report.SNMP.System Summary activity in CatTools is very basic in its operation.

          It runs a series of SNMP Gets to collect basic system information from your device, and also provides you with 5 custom fields for you to enter further OIDs to return additional SNMP data.

          With regards to your SNMP activity, are you using any of the SNMP Custom fields or just the basic defaults?

          Are you seeing any errors in the CatTools Info Log when the activity is run?

            • Re: SNMP System Summary won't work with Fortinet firewalls

              Custom fields with confirmed working OIDs but I also tried without and got the same results. When I run it I get:

              ***SNMP timeout or unknown error

              I don't believe it is a networking issue as I can see the request go from the cattools program to my Fortinet  but my device doesn't respond back. Even when I configured it for debug mode, I don't see the firewall respond at all to the query from the cattools program. I have repeated this test on multiple devices and have received the same results.

              Based off this previous information, I'm guessing the program isn't formulating the snmp request correctly to the fortinet.