2 Replies Latest reply on Aug 11, 2009 8:48 AM by jonchill

    TFTP Transfer Issue

    jonchill

      Up to now I've had no problems using the Solarwinds TFTP client to transfer various things including new firmware to our Cisco switches. I've just tried to transfer a new firmware to a switch today and I get an error in the server window saying Dropped because peer didn't respond I've tried running the server from a different device and done a transfer to a different switch but I get the same result.

      I've checked the network and I can't see a problem with it, its functioning normally with no issues.

      Any help with what could be causing this issue would be good.

       

      Thanks

      Jon

        • Re: TFTP Transfer Issue

          This error occurs in the TFTP server when we have sent 5 retry packets and received no response.  Here are a couple things to look at:

          1. Sniff the traffic and see if there are any TFTP packets originating from the switch back to the server.  There should be a response packet from the switch for every packet sent to the switch.
          2. See if you get different results when initiating the transfer from the command line on the switch (i.e. copy tftp://tftp-server-name-or-ip/bin-file.bin ...).

          If this doesn't get you up and running, send me the sniff and I'll take a look.

            • Re: TFTP Transfer Issue
              jonchill

              While I get the capture, I've also just go the following error message Interrupted by client, received error packet with code: 0 and message session terminated.

              Also I've noticed in NPM while the transfer is happening the CPU goes from around 15% to over 40% and the response time spikes from 2ms to over 20ms so somethings not right somewhere.

              I've tried it from the command line and its the same get the same errors also and it takes for ever and then partly installs the firmware and other files.