6 Replies Latest reply on Jun 1, 2009 9:27 AM by BakerD

    Orion NPM 9.5 Custom Web Reports Error

    lekeosi

      I did a test upgrade of an Orion NPM 9.1 SP5 server to 9.5. The upgrade went well, but I get errors like the one below when I try to view my existing custom reports.

      The "Advanced Alerts " resource is missing.
      The file /Orion.NetPrefMon/Resources/Reports/Report.ascx is not found.

      The Orion server seems to be picking up an invalid location for Report.ascx ie Orion.NetPrefMon instead of Orion.NetPerfMon.

      Any ideas on how I can correct this?

      Ade

        • Re: Orion NPM 9.5 Custom Web Reports Error

          The quick and dirty way to fix this is to edit the database using the database manager.  In the table "Resources" you will see under "ResourceFile" "/Orion.NetPrefMon/...."  you need to change that to "/Orion/NetPerfMon/...." 

          There are a number to correct but after you change that it should fix your issue. 

          • Re: Orion NPM 9.5 Custom Web Reports Error
            JohnMartinich

            lekeosi,

            When you say "Advanced Alerts resource is missing" where are you expecting to see it? Did you have a resource that disappeared or are you missing the option of adding the resource?

              • Re: Orion NPM 9.5 Custom Web Reports Error
                lekeosi

                Hi John,

                I had a resource that disappeared.

                I just tried lasher's recommendation and that seems to have fixed the problem. I changed the Orion.NetPrefMon part of the text to Orion/NetPerfMon

                Thanks lasher.

                  • Re: Orion NPM 9.5 Custom Web Reports Error
                    BakerD

                    I'm having the same problem with a resource on my home page that pulls in a report.  I get the same error of report.ascx is not found for my resource.  I had two entries in my DB resource table that showed orion.netprefmon and I change the "." for a "/" and it didn't work for me.

                    I do have my website installed on a different drive than the SW program, but it has never been an issue for any other upgrades over the past several years.

                     

                    I have a case open with support, but just wanted to post that the above fix may not work for everyone with that error.

                      • Re: Orion NPM 9.5 Custom Web Reports Error
                        casey.schmit

                        Change the '.' to a '/' isn't the only change to make.  It's also necessary to correct the 'netprefmon' to 'netperfmon'.

                        Another solution, if you're not comfortable heading into the DB is to remove the resource from the view and re-add it.

                          • Re: Orion NPM 9.5 Custom Web Reports Error
                            BakerD


                            Change the '.' to a '/' isn't the only change to make.  It's also necessary to correct the 'netprefmon' to 'netperfmon'.

                            Another solution, if you're not comfortable heading into the DB is to remove the resource from the view and re-add it.

                             

                             



                             

                            Ahhh, totally missed that.  Now my report resource shows up on my homepage as it used to, yeah :).  Thanks

                            One issue down, more to go :(.