15 Replies Latest reply on Sep 1, 2009 2:33 PM by mleinio

    NetPerfMonService refuses to stop

    efosshaug

      Hi.

      We have had this problem since our first Orion installation. Since then I hav upgraded, reinstalled, changed hardware, but the problem still is there.

      During reinstall, upgrade or running the Config Wizard the netperfmonservice service refuses to stop. The only way to stop it is to kill it using TaskMan. But, after a few minutes it is running again. So I have to whatch taskman an kill it over and over. I have to do this because it can't be upgraded when running. Usually I set it to Disabled before upgrade or wizard but this creates other problems.

      This is only anoying - no big problem since I allways get the job done. And - it is a good thing that the service loves to run during normal use.

      But, on every upgrade or change I have to run the wizard two to four times to make all right.

      Any advice?

        • Re: NetPerfMonService refuses to stop
          jawill8301

          I've had the same problem.  I have always linked it to the database or sqlservice.  I hated doing it but I've had to kill the sqlserver service in order to get my upgrades.  I can only imagine how corrumpt I'm making the database.  We monitor 1018 Nodes, 3958 Interfaces, 10 Volumes, 4986 Total Elements.  We also have a problem with our polling rarely getting to 99%.  Do you experience any of those problems?

            • Re: NetPerfMonService refuses to stop
              Mike C

              No need to kill your DB (and possiblly corrupting it), this is due to NetPerfMon constantly read/write to DB,  just kill NetPerfMon Service via task manager after setting service to disable in the service properties tab.  We monitor over 15,000 elements (5861 nodes, 8.345 Interfaces, and 2103 volumes) and we run at approx 99.6% polling completion, go into your Poller tuning settings and set to the recommended values, this will help.

                • Re: NetPerfMonService refuses to stop

                  This is a known issue that we are addressing in a service pack.

                    • Re: NetPerfMonService refuses to stop
                      bleearg13

                      The biggest problem with killing the service before an upgrade is that even though you've disabled automatic startup upon failure, the re-install resets these values.  It installs the service, starts it, then tries to stop/restart it again before completing the installation.  Highly annoying and makes installations, upgrades, and patching a complete pain in the ****.  I am hopeful that this problem will be resolved in a service pack, as it's been happening since at least 7.x.

                          • Re: NetPerfMonService refuses to stop
                            bshopp

                            We made some changes with 9.5 and the SP's, so hopefully this should be alot better

                              • Re: NetPerfMonService refuses to stop
                                efosshaug

                                Hi.

                                Well - it is not better. I have just installed SP3 and this was the same trouble. And now also SolarWinds.BusinessLayerHost.exe has the same problem. Refuses to stop as NetPerfMonService.

                                But, the installer of SP has been better.

                                What I do is to go to Services - set all Solarwinds services to disabled. Use the Orion Service Manager to stop everything. Use taskmanager to kill the processes that will not stop.

                                Then install the upgrade. Earlier this failed because the services didn't start since they where disabled, but now they are set back to Automatic by the installer and the installation goes in one step. Earlier I had to set them back to Automatic myself and then run the Wizard and help the Wizard to stop the processes with Task Manager.

                                So - when using Disabled I finished the upgrade in good time.

                                • Re: NetPerfMonService refuses to stop

                                  We made some changes with 9.5 and the SP's, so hopefully this should be alot better

                                  Hi, no it isn't, the netperfmonservice.exe is still taking ages to shutdown when asked.

                                  Markku

                                    • Re: NetPerfMonService refuses to stop
                                      smcdonald

                                      Hmm - yeah - I still see the same problem running with NPM v9.5 sp3.
                                      This problem has been around for what seems forever now (way back in v8 days at least) - I'm well used to killing and disabling the services when doing upgrades/service packs.  I keep hearing it's getting fixed but still no joy...  It seems directly related to the number of pollers - if you dont have that many the service does shut down nice and quick.  But with one of my polling engines running around 9000 elements it takes about 20 minutes for the service to stop (you can see it slowing unwinding memory as it stops).

                                      I wouldn't mind that much but it's a real pain when I'm doing upgrades/service packs as I keep having to kill the service to get the upgrade going...

                        • Re: NetPerfMonService refuses to stop
                          Stacy Patten

                          I had to perform the upgrade to 9.5 four times to get it to finish properly.

                          • Re: NetPerfMonService refuses to stop
                            Mike C

                            This is caused by the fact that the NetPerfMon Service is almost constantly reading/writing to the DB and that the Service is set to auto start itself (when you kill from Task manager)  Our standard procedure is to set the NetPErfMon (and Netflow) services to disabled, then kill via task manager.  Once install or upgrade is done, reset to auto and start service.  We have always done this and have had no issues.

                            1 of 1 people found this helpful
                            • Re: NetPerfMonService refuses to stop

                              We have also experienced this and I cant believe Solarwinds has not fixed this issue since V7.....