12 Replies Latest reply on Feb 26, 2009 9:02 AM by Andrew Story

    IPMonitor and IIS / Tomcat

    Andrew Story

      Is it possible to monitor iis / tomcat linked using /jakarta/isapi_redirect.dll
      Iis is on port 80, tomcat is on port 8080

      We can monitor each directly, but can't setup a monitor that references a file on the tomcat via the iis server
      In a web browser if we go to http://server:80/LionShare/blank.html then it goes to the iis server and gets seamlessly passed through to the tomcat server. If we try the same on ipMonitor then we get a 404 error in the iis logs

      Cheers, Andy

        • Re: IPMonitor and IIS / Tomcat
          Fodome

          Andy,

          From the ipMonitor system, open a CMD window and type  "telnet  server 80"

          Once connected, type the following commands, without making any errors (otherwise, you'll need to start over):

          GET /LionShare/blank.html HTTP/1.0
          HOST: server

          Hit Enter twice.

          What do you get as a response?

          PS: Naturaly you'll want to replace the referrences to 'server' with the actual address of the web site.

          Let me know

          Chris Foley - SolarWinds - Support Specialist
          Support:  866.530.8040  |  Fax: 819.772.1625
          network management simplified  |  solarwinds.com

            • Re: IPMonitor and IIS / Tomcat
              Andrew Story

              Hi Chris,

              I get a 401 error. Is  there a way of entering credentials using this  method?

              HTTP/1.1 401 Access Denied
              Server:  Microsoft-IIS/5.0
              Date: Tue, 03 Feb 2009 17:22:17 GMT
              WWW-Authenticate:  Negotiate
              WWW-Authenticate: NTLM
              Content-Length: 4431
              Content-Type:  text/html

                • Re: IPMonitor and IIS / Tomcat
                  Andrew Story

                  Some more info Chris,

                   

                  Enabling 'Allow anonymous access' in IIS lets me telnet and get a 200 repsonse (success)

                  However, doing this from IPMonitor, using no credentials and a domain account still gives me the same error whether 'Allow anonymous access' is unchecked or not.

                  Any more ideas?

                   

                  Thanks, Andy

                  • Re: IPMonitor and IIS / Tomcat
                    Fodome

                    Andrew,

                    If the web site requires NTLM authentication, perform the following:

                    1. Within the Monitor, click the "Select" button next to "Credential for Monitoring".

                    2. Click the "New Credential" button.

                    3. Enter a name for the Credential and click "Next"

                    4. Select "NTLM Authentication (Windows NT Lan Manager)" and click "Next"

                    5. Enter the Domain name and username of the Windows account you normally use to login to the web site.  Then, enter the password and confirm it.

                    6. Click "Next", "Finish" and then "Apply"

                    7. Now back at the Monitors settings page, click "Force Test".

                    If the Monitor still fails,

                    1. Within the address bar, at the very end, add the word "Debug" and press enter.

                    2. On the grey bar, you should now have a "Debug" button.  Click it.

                    3. A new window should come up with a log of what was requested by ipMonitor and what was received.

                    Let me know what that is, as needed.

                    Sincerely,

                    Chris Foley - SolarWinds - Support Specialist
                    Support:  866.530.8040  |  Fax: 512.857.0125
                    network management simplified  |  solarwinds.com

                      • Re: IPMonitor and IIS / Tomcat
                        Andrew Story

                        Chris, where do I type "DEBUG".  I've tried it in numerous locations (includung the IPMonitor URL on the monitor page) and I don't get a debug button appear anywhere in the IPMonitor gui.

                        If you could let me know please, cheers.

                          • Re: IPMonitor and IIS / Tomcat
                            Andrew Story

                            Any more ideas Chris/anyone?

                            • Re: IPMonitor and IIS / Tomcat
                              Fodome

                              Andrew,

                              The following screenshot might help.  Simply add "debug" to the URL, press Enter and then click the "Debug" button.

                              Note that this feature only works for HTML/ASP and HTTPS monitors.

                              Let me know if this helps.

                              Chris Foley

                                • Re: IPMonitor and IIS / Tomcat
                                  Andrew Story

                                  Thanks Chris, will try in work tomomrrow.

                                    • Re: IPMonitor and IIS / Tomcat
                                      Andrew Story

                                      Hi Chris,

                                       

                                      Please see debug output, not sure if this is of any use,hopefully the full txt file will be pasted:

                                       

                                      GET /LionShare/blank.html HTTP/1.0
                                      User-Agent: Mozilla/4.0 (compatible; ipMonitor 9.0)
                                      Host: 10.0.33.71
                                      Connection: Keep-Alive

                                      -------------
                                      <recv>
                                       <ver>HTTP/1.1</ver>
                                       <status>401</status>
                                       <header>
                                        <name>Server</name>
                                        <value>Microsoft-IIS/5.0</value>
                                       </header>
                                       <header>
                                        <name>Date</name>
                                        <value>Fri, 13 Feb 2009 11:04:40 GMT</value>
                                       </header>
                                       <header>
                                        <name>WWW-Authenticate</name>
                                        <value>Negotiate</value>
                                       </header>
                                       <header>
                                        <name>WWW-Authenticate</name>
                                        <value>NTLM</value>
                                       </header>
                                       <header>
                                        <name>Content-Length</name>
                                        <value>4431</value>
                                       </header>
                                       <header>
                                        <name>Content-Type</name>
                                        <value>text/html</value>
                                       </header>
                                      </recv>
                                      -------------
                                      GET /LionShare/blank.html HTTP/1.0
                                      Authorization: NTLM TlRMTVNTUAABAAAAB4IIogAAAAAAAAAAAAAAAAAAAAAFAs4OAAAADw==
                                      User-Agent: Mozilla/4.0 (compatible; ipMonitor 9.0)
                                      Host: 10.0.33.71
                                      Connection: Keep-Alive

                                      -------------
                                      <recv>
                                       <ver>HTTP/1.1</ver>
                                       <status>401</status>
                                       <header>
                                        <name>Server</name>
                                        <value>Microsoft-IIS/5.0</value>
                                       </header>
                                       <header>
                                        <name>Date</name>
                                        <value>Fri, 13 Feb 2009 11:04:40 GMT</value>
                                       </header>
                                       <header>
                                        <name>WWW-Authenticate</name>
                                        <value>NTLM TlRMTVNTUAACAAAACgAKADgAAAAFgomilDgXyHsKMNMAAAAAAAAAAKgAqABCAAAABQCTCAAAAA9KAFcALQBVAEsAAgAKAEoAVwAtAFUASwABABYAVQBLAFMAQgBDAFMAVwBFAEIAMAAzAAQALgBqAHcALQB1AGsALgBqAGEAbQBlAHMAdwBhAGwAawBlAHIALgBjAG8ALgB1AGsAAwBGAHUAawBzAGIAYwBzAHcAZQBiADAAMwAuAGoAdwAtAHUAawAuAGoAYQBtAGUAcwB3AGEAbABrAGUAcgAuAGMAbwAuAHUAawAAAAAA</value>
                                       </header>
                                       <header>
                                        <name>Connection</name>
                                        <value>keep-alive</value>
                                       </header>
                                       <header>
                                        <name>Content-Length</name>
                                        <value>4033</value>
                                       </header>
                                       <header>
                                        <name>Content-Type</name>
                                        <value>text/html</value>
                                       </header>
                                      </recv>
                                      -------------
                                      GET /LionShare/blank.html HTTP/1.0
                                      Authorization: NTLM TlRMTVNTUAADAAAAGAAYAHYAAAAYABgAjgAAAAoACgBIAAAADgAOAFIAAAAWABYAYAAAAAAAAACmAAAABYKIogUCzg4AAAAPagB3AC0AdQBrAHMAYQBJAFAATQBPAE4AVQBLAFMAQgBDAFMATQBPAE4AMAAxAIsXVuprgsUoAAAAAAAAAAAAAAAAAAAAADgT97JPQn484/fFGbzCv3Su8cOMWA0xiA==
                                      User-Agent: Mozilla/4.0 (compatible; ipMonitor 9.0)
                                      Host: 10.0.33.71
                                      Connection: Keep-Alive

                                      -------------
                                      <recv>
                                       <ver>HTTP/1.1</ver>
                                       <status>404</status>
                                       <header>
                                        <name>Server</name>
                                        <value>Microsoft-IIS/5.0</value>
                                       </header>
                                       <header>
                                        <name>Date</name>
                                        <value>Fri, 13 Feb 2009 11:04:40 GMT</value>
                                       </header>
                                       <header>
                                        <name>Content-Length</name>
                                        <value>4040</value>
                                       </header>
                                       <header>
                                        <name>Content-Type</name>
                                        <value>text/html</value>
                                       </header>
                                      </recv>
                                      -------------

                                       

                                      If any of this makes sense I'm all ears :]

                                      Cheers, Andy

                            • Re: IPMonitor and IIS / Tomcat
                              Andrew Story

                              Chris,

                               

                              Checking the 'allow anaonymous access' box in IIS allows me to telnet and get a 200 response (success)

                              H, trying this in IPMonitor I get the same error no matter what account I use to authenticate, and with both 'Allow anonymous access' enabled and siabled.