7 Replies Latest reply on Nov 26, 2008 2:57 AM by tester1112

    Webconsole no login NPM 9

      Hey,


       


       I downloaded NPM test package from your server. Installed it, and cannot login into the Webconsole under http://localhost:8787.


      It says: Login failure. Username and/or Password incorrect.


      I searched inside this forums around - tried nearly every thing descriped here in the forum. Nothing was working.


      My enviroment:


      - Windows Server R2 german, SP2 and all up-to-date updates!


      - .NET 1.1, 2.0 SP1, 3.0 SP1, 3.5 installed.


      - IIS complete installed


      - MS SQL Express 2005 (here I tested the release from Microsoft side - german, as well as the inside the Testpackage from you - engl. version).


       - Installation of all software and OS as out-of-the-box - I made NO changes in folders/naming/rights/or others!!


      As I said, I looked around inside this forum, and found several post with the same problem. For me it seems a major problem, but as well, it seems there is no support/fix regarding this. As I see this as a major feature, it may be the keypoint to purchase or not. Momentarily not!


      The other modules are working quite well - only the Webconsole sucks...


      I wasted around 2-3 days with tests, reinstallings and so one. I realy would be happy if anyone could give me a hint or 'way to work around', i doubt there is a solution with 'one mousclick'.


      To the 'alway-open-ticket' question -where please?


      I gave my credentials into your system to download the testpackage, but when going to support, i will be asked about customer id - got none, from where should I get this no. please?


      w. best regards

        • Re: Webconsole no login NPM 9
          denny.lecompte

           Tester,

           What user name and password are you using?  If you didn't change anything, we use "Admin" and "".  That is, don't type anything in the password field.  That's probably not the problem, but I need to make sure. 

            • Re: Webconsole no login NPM 9

              Hey denny,


               


              exactly as described.


              User: Admin  and  PW: ''.


              If needed, say how to enable debug or an advanced logging. As I see, you using Log4net, so it should be possible to set the loglevels. I started Orion Diagnostics - looked inside the Zip, found no entry inside the OrionWeb.log. If wished, I can provide the diagnosis file.


               w.b.regards


               


               And by the way... another curiosity:


              As said I installed the testpackage - with 30days of testingtime. Well, the normal Orion programms are displaying the daycounter. But not the web console, here i always see 30 days left.


                • Re: Webconsole no login NPM 9

                  Hey denny,


                   


                  a 2nd note onto this topic:


                  I looked inside the DB - found the entry for the accounts:


                  1.) AccountID: admin - PW: 138-717102-266-324922  (<-- hm, so this is the password for 'empty' )


                  2.) AccountID: guest - PW: 85-01759-6-493944980


                  Tested: I overwrote them with '' (empty) - then tested login - no change, same login failure.

                    • Re: Webconsole no login NPM 9
                      denny.lecompte
                       I spoke with Dev, and they suggested that you try changing the log level in \inetpub\solarwinds\web.config. Find the <threshold value="…"/> line in the log4net section and change WARN to DEBUG. Then try to log in again. See what shows up in OrionWeb.log . 
                      • Re: Webconsole no login NPM 9

                        Got It,


                         


                         but PEOPLE - WHAT ARE YOU PROVIDING - To be honest, a real **** testsystem - did you ever tested it!?


                        If this is your software as it will be delivered I doupt people will be very satified - I am not!


                        It took me roughtly 4 days to figure it out for our firm, this is in Euro speaking around 5000. Do you pay test and evaluation errors - I dont think so.


                         


                        To the error:


                        As I wrote earlier, i looked around your system and DB, as well as inside coding (and I dont' want to hear anything about leagal aspects - if you cannot provide somthing working!). Here I figured out your refering to the DB table 'Accounts', here to the field 'AccountsID'. There you set the Password AND inside the field 'AccountEnabled' if the account(s) are enabled. But luckilly you are not setting the Admin account to BE enabled! - Changing this to Y - and now it works. Thanks for the testing!


                        still, with best regards, a very disappointed customer...


                          • Re: Webconsole no login NPM 9
                            denny.lecompte

                            I appreciate that you're frustrated, and clearly, your experience has not been good.  I will note that we have thousands of downloads every week, and your particular problem is not something we see.  There's something with your environment and our software that doesn't seem to mix well.

                            Please give us a chance to help you.  You're not a customer, so Support won't take your call, but if you contact Sales (sales@solarwinds.com), our Sales Engineers will help you troubleshoot your issue.

                              • Re: Webconsole no login NPM 9

                                Hey danny,


                                without question - thanks for the help. Appreciated


                                But, your development makes it too easy - saying its a matter of my configuration. Well, the configuration is as said 'out-of-the' box. What I see is, that setup was not setting the flag 'AccountsEnabled' to true ('Y'). This minor error causes major problems.


                                I accept, that support will not go into testcases because of costs. They may become unforseeable.


                                I fixed the error onto my costs for my firm so my people can try it out, to be clear. You can now use this fix for other testcustomers, or customers how have a similar problem. Because I think its not a enviroment (since when has a SQL sentence an enviroment dependency?) but a bug inside the setup. If you use automatic tools to deploy and create the setup, you should have a look inside them first.


                                 w.b. regards