7 Replies Latest reply on Sep 29, 2010 11:11 AM by jmjordan

    VMWare ESX & Orion 9.1

    aLTeReGo

      I'm having a little problem monitoring our VMWare ESX servers using Orion 9.1. I know the problem isn't with Orion, but I figured this would be a great place to ask the question. Essentially, the problem I'm having is all the cool new SNMP information that's presented in Orion 9.1 isn't populated and I'm not sure why. 


      When I list resources via SNMP on the ESX Server all that's listed is "CPU & Memory Utilization". What's really strange is when I look at the system description it reads..


      Description   VMware ESX Server 0 VMware, Inc. 0 0 i686 


      The version information is obviously incorrect. I'm running VMWare ESX Server v3.5. Does anyone have any idea what might be wrong with the SNMP configuration on my ESX Server? Any help would be greatly appreciated. Thanks.

        • Re: VMWare ESX & Orion 9.1
          Matthews

          Do you have the line in your snmp config files that allows the vmware specific mibs to be used? 


          after your snmp specific info you will need the line


          dlmod SNMPESX            /usr/lib/vmware/snmp/libSNMPESX.so


           


           besides that the snmpd config i have is very barren


           


          syscontact "contact"


          syslocation "location"


          rocommunity public


          trapcommunity public


          trapsink localhost


           


          Another place to look could be that your system name could be blank. 


          The easiest place to change that would be in the infrastructure client go to "configuration > dns and routing > properties" from here you should be able to change your name and domain which is what you should be getting when you poll for sysdescr.0 mib.
           


          Regards,

            • Re: VMWare ESX & Orion 9.1
              aLTeReGo

              Do you have the line in your snmp config files that allows the vmware specific mibs to be used? 

              Do you mean the "/etc/snmp/snmpd.conf" or elsewhere?

              • Re: VMWare ESX & Orion 9.1

                I found another step that was a problem for me on almost every one of my ESX 3.5 hosts.

                There are two different instances of snmp services running.  If both are enabled, then neither one will work correctly. 

                There is one config found in /etc/vmware/snmp.xml.  To turn this one off you change the "true" value to "false".

                http://communities.vmware.com/message/1093260#1093260 supports this part.

                 

                The other config is /etc/snmp/snmpd.conf.  This is described in most places around.

                 

                The disconnect for me had been that both were set as enabled respectively.

                I turned the snmp.xml value to false.

                Then had to run the following commands: 

                [root@Server root]# service snmpd restart
                Stopping snmpd:                                            [FAILED]
                Starting snmpd:                                            [  OK  ]
                [root@Server root]# service mgmt-vmware restart
                Stopping VMware ESX Server Management services:
                   VMware ESX Server Host Agent Watchdog                   [  OK  ]
                   VMware ESX Server Host Agent                            [  OK  ]
                Starting VMware ESX Server Management services:
                   VMware ESX Server Host Agent (background)               [  OK  ]
                   Availability report startup (background)                [  OK  ]
                [root@Server root]# service snmpd restart
                Stopping snmpd:                                            [FAILED]
                Starting snmpd:                                            [  OK  ]
                [root@Server root]# service mgmt-vmware restart
                Stopping VMware ESX Server Management services:
                   VMware ESX Server Host Agent Watchdog                   [  OK  ]
                   VMware ESX Server Host Agent                            [  OK  ]
                Starting VMware ESX Server Management services:
                   VMware ESX Server Host Agent (background)               [  OK  ]
                   Availability report startup (background)                [  OK  ]
                [root@Server root]# service snmpd restart
                Stopping snmpd:                                            [  OK  ]
                Starting snmpd:                                            [  OK  ]

                The reason I ran both commands twice was because, as you can see, the snmpd service wouldn't stop successfully the first time.