7 Replies Latest reply on Nov 16, 2011 3:15 PM by derhally

    Unable to Start flow capture

       Hello,

       I have installed the free SolarWinds Real-time Netflow analyzer. I managed to add the netflow device and all the interfaces that are configured with netflow export is reflected. There are in and out traffic reflected under the "traffic in/out" column but there is no "green" tick under "sending netflow" column. When i select one of the interface and click "Start flow capture", an error message pop out

      "Netflow is not detected on the selected interface.

      Please select another or configure the interface to send Netflow data to the host NetFlow Realtime is running on." (i wanted to paste the screen into this post but i was unable)


      I find it strange that since the interfaces are reflected, that means Real-time Netflow analyzer has recieved netflow information from the configured device. I do not understand why i am getting the error message.

       I got it working once by deleting and re-adding the device again. But the next day i execute the program again, it does not work. I tried to delete and re-add the device again, but this time it does not work. I rebooted the servers several times as well. I have check the router netflow settings by doing show ip flow export and the interfaces are exporting data correctly.
       

       Please advice. Thanks.
       

       

        • Re: Unable to Start flow capture

           I've experienced the same problems.  I've tried several times to capture traffic using this tool, but I've only seen the green checkmark once.  Nothing has changed in my NetFlow configuration nor in the configuraiton of the Real-time NetFlow Analyzer since that one time I was able to perform a capture.  I have my list of devices with traffic in and out values presented as well.

          My guess is that reported traffic in/out values may be coming from SNMP stats, but that's just speculation.  However, I don't understand why my NetFlow data is not being detected.

          Hopefully someone from SolarWinds can chime in here.

            • Re: Unable to Start flow capture

              I am having the same issue.  I installed the latest 9.2.1.25 and it did not help at all.  I have never seen the green check in the sending netflow column and I get the "Netflow is not detected on the selected interface" when I try to start a capture.

              I am able to see all the interfaces on my router and the traffic in and out values are updated. 

              I would really like to get this working but can't seem to get past this.  Everything on the router side seems to be configured correctly.  I do have subinterfaces, but I configured the ip route-cache flow on the fastethernet 0/0 interface and set the same to be the flow-export source.  I specified version 5 as well.

              I tried calling Solarwinds support but was told that support is not available for any of the free tools.  Hopefully this site can provide some assistance.

                • Re: Unable to Start flow capture
                  d_shah

                   I am also having the same issue. I have enabled netflow on Cisco 4500 switch:

                   
                  When I try to capture real-time netflow I get the following message.
                   
                   "NetFlow is not detected on the selected interface.
                   
                  Please select another or configure the interface to send Netflow data to the host NetFlow Realtime in running on"
                   
                   
                  Any insite will be helpfull
                   
                   
                  Netflow is enabled on the Cisco 4500 switch and we have a netflow card installed on it.  Here are the commands which were used on 4500 switch:
                   
                  ip route-cache flow
                  ip flow ingress
                  ip flow ingress layer2-switched
                  ip flow-export source FastEthernet3/1
                  ip flow-export version 5
                  ip flow-export destination 130.xx.xx.xx 2055
                   
                   
                  The netflow version running is 9.2.0.47
                   
                  Am I missing something??
              • Re: Unable to Start flow capture

                Ahoy lads,

                I understand that this topic is a year old, however I have an answer to close this topic and help future users.

                We've been having a similar problem as the rest of you, where we installed this program, but could not start the capture. To answer your question derhally (which I get the feeling you did not bother to read everyone elses responses), we did not see any green checkmarks in the Recieving NetFlow column.

                After spending several hours searching through the internet, we finally figured out how to get the program to work:

                In the router configuration, each physical interface should have the following command entered:

                "ip nbar protocol-discovery"

                Add that command, and we're sure that you'll start seeing green checkmarks all over the place.

                2 of 2 people found this helpful
                • Re: Unable to Start flow capture
                  Sparky70

                  Not detecting Netflow from ASA 5510 8.2.1

                  According to this forum thread, the free Real-Time Netflow Analyzer does not support Netflow Version 9 that is used on Cisco ASA devices.  Nor does it seem like it will anytime soon.

                  I own the Engineer's Toolset, which includes this tool, so I'm very surprised that this is not something they would take into consideration when bundling it together. I paid for a set of tools, including the yearly maintenance support costs, and now have one that does not work.  IMO, this should be fixed or a partial refund should be offered.

                  I can confirm, using the trial version, that Orion Network Performance Monitor (NPM) with the Netflow Traffic Analyzer (NTA) module does work.  I guess you get what you pay for.

                  That thread does provide an alternate free solution outside of the SolarWinds family - http://www.manageengine.com/products/netflow/cisco-netflow.html