15 Replies Latest reply on Sep 9, 2008 7:06 PM by Debugger

    Exchange 2003 - invalid server or credentials

      I have installed the exchange monitor on a win xp computer and am trying to connect to the exchange server 2003. But i keep getting an message saying invalid server or credentials. Windows firewall is disabled on the xp machine and no windows firewall on the server. I am very sure that the server and user credentials that i have provided are correct.


      This is the error message : Unable to connect to the remote server access is denied exception from hresult : 0x80070005(E-AccessDenied)


      Am breaking my head on how to solve this.


      Any help on this would be much appreciated.

        • Re: Exchange 2003 - invalid server or credentials
          mark wiggans

          Try forcing a refresh of WMI classes on the target server being queried, use the following command within a "cmd.exe" prompt.

          Windows 2000: winmgmt /resyncperf
          Windows XP, 2003, Vista: wmiadap.exe /f

            • Re: Exchange 2003 - invalid server or credentials

              I tried that but still get the same error


                • Re: Exchange 2003 - invalid server or credentials
                  chris.lapoint

                  From the machine where you are trying to run the Exchange Monitor could you please try verifying WMI connection using WBEMTEST? You should try connecting to the Exchange Server (\\EXCHANGE_SERVER\root\default) and specify the credentials you are using in Exchange Monitor. Then run the followin query

                  SELECT LocalQueueLength from Win32_PerfRawData_SMTPSVC_SMTPServer

                  This should give you a more detailed error of why we are running into this issue.

                    • Re: Exchange 2003 - invalid server or credentials

                      This is the error message i get when i try WBEMTEST


                      On the namespace I put in \\exchangeserver\root\default


                      and in credentials i typed in the username and password and when i clicked on connect i got this error message


                      Number: 0x80070005
                      Facility: Win32
                      Description: Access is denied.

                        • Re: Exchange 2003 - invalid server or credentials
                          chris.lapoint

                          Have you enabled remote access to WMI on your Exchange 2003 server?  I've included steps below.

                          To enable DCOM permissions for your Exchange Monitor credential:

                          1. Log on to the computer you want to monitor with an administrator account.
                          2. Navigate to Start > Control Panel > Administrative Tools > Component Services. You need to switch to the Classic View of the Control Panel to use this navigation path. You can also launch this console by double-clicking comexp.msc in the /windows/system32 directory.
                          3. Expand Component Services > Computers.
                          4. Right-click My Computer, and then select Properties.
                          5. Select the COM Security tab, and then click Edit Limits in the Access Permissions grouping.
                          6. Ensure the user account you want to use to collect WMI statistics has Local Access and Remote Access, and then click OK.
                          7. Click Edit Default, and then ensure the user account you want to use to collect WMI statistics has Local Access and Remote Access.
                          8. Click OK.
                          9. Click Edit Limits in the Launch and Activation Permissions grouping.
                          10. Ensure the user account you want to use to collect WMI statistics has Local Launch, Remote Launch, Local Activation, and Remote Activation, and then click OK.
                          11. Click Edit Default, and then ensure the user account you want to use to collect WMI statistics Local Launch, Remote Launch, Local Activation, and Remote Activation.
                          12. Click OK.

                          Enabling Account Privileges in WMI

                          The credential you want to use for monitoring Exchange Server must have security access to the namespace and subnamespaces of the monitored target computer. To enable these privileges, complete the following procedure.

                          To enable namespace and subnamespaces privileges:

                          1. Log on to the computer you want to monitor with an administrator account.
                          2. Navigate to Start > Control Panel > Administrative Tools > Computer Management > Services and Applications. You need to switch to the Classic View of the Control Panel to use this navigation path.
                          3. Click WMI Control.
                          4. Right-click WMI Control, and then click Properties from the shortcut menu.
                          5. Click the Security tab, expand the Root group, and then click CIMV2.
                          6. Click Security and then select the user account used to access this computer and ensure you grant the following permissions:
                            • Enable Account
                            • Remote Enable
                          7. Click Advanced, and then select the user account used to access this computer.
                          8. Click Edit, select This namespace and subnamespaces in the Apply to field, and then click OK.
                          9. Click OK on the Advanced Security Settings for CIMV2 window.
                          10. Click OK on the Security for Root\CIMV2 window.
                          11. Click Services in the left navigation pane of Computer Management.
                          12. Select Windows Management Instrumentation in the Services result pane, and then click Restart.

                          Allowing WMI through the Windows Firewall

                          You must allow WMI traffic through the firewall of the monitored application server. The following procedure walks you through allowing WMI through the Windows Firewall.

                          To allow WMI traffic through the Windows Firewall:

                          1. Log on to the computer you want to monitor with an administrator account.
                          2. Navigate to Start > Control Panel > Security Center. You need to switch to the Classic View of the Control Panel to use this navigation path.
                          3. Click Windows Firewall in the left navigation pane.
                          4. Click Allow a program through Windows Firewall in the left navigation pane.
                          5. Check Windows Management Instumentation (WMI), and then click OK.