8 Replies Latest reply on Apr 2, 2008 4:27 PM by greg@solarwinds.net

    Unable to install 9.2 SP1

    rgward

      Downloaded v9.2 and installed without issue today.  Downloaded Toolset v9.2 Service Pack and get following error when executing update.exe.


      Installing SolarWinds Toolset 9.2 SP1


      'REG' is not recognized as an internal or external command,
      operable program or batch file.
      Error: Can't find the Toolset Installation.


      Press any key to continue . . .


       


      Has anyone encountered this?


       


        • Re: Unable to install 9.2 SP1
          JasonKV

          I am having the same problem. Please help.

           

          Thanks. 

            • Re: Unable to install 9.2 SP1

               JasonKV - REG is a command line utility that ships with XP/2000 that allows a user to modify the registry.

              Here are some questions that might help us figure out why it is not working on your system: 

              What OS are you running on?

              Is reg.exe in your path?

              Are you running the update as an adminstrator?
               

              Thanks,

              Greg 

                • Re: Unable to install 9.2 SP1
                  JasonKV
                  I just spent the time between posts doing some further investigation to see if it was in fact a problem on my side. I have come to a similar conclusion that you have just told me. I have read that although REG.EXE is included with the Windows 2000 package it must be installed manually (not part of auto install). With this in mind I would expect Solarwinds to release a version of the update that is compatible with 2000 in its native state. Just incase I will still answer your questions for accuracy.

                  OS - Windows 2000.
                  REG.EXE is not on my computer anywhere (I searched)...therefore not in my path (I checked).
                  I am running Update as an administrator.

                    • Re: Unable to install 9.2 SP1

                       Thanks Jason - and sorry for the confusion there.  I will update the docs for the service pack to include this important bit of info, as well as make sure the next hotfix plays nice with the native install on 2000.

                       

                      Thanks,

                      Greg 

                        • Re: Unable to install 9.2 SP1
                          JasonKV
                          Just for another point of clarification.

                          Will you be sending me an Updated version of the current Hot Fix (SP1) that does play nice with 2000? I would expect this as a customer with a purchased product. Although I am Administrator on my PC the core responsibility of administering changes falls on our PC Support group, so changes even as "simple" as adding reg.exe is out of my control. In addition my group has 13 licenses of Engineers Toolset that would need to have their PC's updated in order to have the Engineers Toolset work. This is a very extensive and time-consuming process to get all PC’s updated in order to install a vendor’s application.